ValerevnaRustam1072
?>

Составьте программу которая запрашивает целое число x и определяет, является ли это число двузначным/трёхзначных.

Информатика

Ответы

kas80

#include <iostream>

#include <string>

int main()

{

   std::string number;

   std::cin >> number;


   std::cout << number << " - " << number.length() << "-х значное число." << std::endl;

   return 0;

}

smint056950

Создать файл X компонентами которого являются элемента массива M. Переписать из файла X в файл Y все компоненты, которые стоят на четных местах. Прочитать файл Y.

M = (0,1; 5,6; 0.8; 2,4; 7,3; 6,8; 0,5; 2,3;)

Решение

 

Описание переменных:  

M - массив-константа;

x, y - переменные, связанные с типизированными файлами;

n - считанное из файла очередное число;

i - счетчик.

Алгоритм решения задачи:  

Создать константу-массив, присвоив ей заданные значения массива.

Связать файловые переменные с соответствующими файлами.

Открыть файл X на запись. Записать в него все элементы массива. Закрыть файл.

Открыть файл X на чтение, а файл Y на запись. Присвоить счетчику значение 1. Пока не будет достигнут конец файла X, считывать из него очередное число. Если при этом счетчик имеет четное значение, то записывать число в файл Y. После считывания и проверки на четность номера очередного числа, увеличивать счетчик на 1. После того как файл X будет прочитан, закрыть оба файла.

Открыть файл Y на чтение. Пока не будет достигнут его конец, считывать из него очередное число и выводить его на экран. После завершения цикла закрыть файл.

Программа на языке Паскаль:  

 

const M: array[1..8] of real = (0.1, 5.6, 0.8, 2.4, 7.3, 6.8, 0.5, 2.3);

var  

   x,y : file of real;

   n: real;

   i: byte;

begin

   assign(x,'x.dat');

   assign(y,'y.dat');

 

   rewrite(x);

   for i:=1 to 8 do

       write(x, M[i]);

   close(x);

 

   reset(x);

   rewrite(y);

   i := 1;

   while not EOF(x) do begin

       read(x, n);

       if not odd(i) then

           write(y, n);

       i := i + 1;

   end;

   close(x);

   close(y);

 

   reset(y);

   while not EOF(y) do begin

       read(y, n);

       write(n:5:1);

   end;

   writeln;

   close(y);

Объяснение:

sklad2445

Передача информации  — физический процесс, посредством которого осуществляется перемещение знаков (сведений предоставлять информацию) в или осуществляется физический доступ субъектов к знакам.

Передача информации — заблаговременно организованное техническое мероприятие, результатом которого становится воспроизведение информации, имеющейся в одном месте (так называемый источник информации), в другом месте (приёмник информации). Данное мероприятие предполагает предсказуемый срок получения указанного результата; «информация» здесь понимается в техническом аспекте, как осмысленное множество символов, чисел, параметров абстрактных или физических объектов, без достаточного «объёма» которого не могут быть решены задачи управления, выживания, развлечения, совершения финансовых операций, каких-либо действий, в т.ч. преступных, и т.д.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая запрашивает целое число x и определяет, является ли это число двузначным/трёхзначных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kostmax1971
Альберт Татьяна
MikhailNechaeva
minchevaelena23
Kulikovvl9
ogonizoloto
vet30
mashuska
oliayur4encko
Amelin-Alipova
Soliyabronzoni
Litvin_Ivanov
Коробкова1437
Asira926
MelnikovaIvanovna