Составить программу к : сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при вложенный циклов pascal abc
Из чисел, представленных в ответах, первое, очевидно, меньше Асравните поразрядно А = 1001 1101 С = 1001 1010.Числа в ответах 2), 3), 4) больше А, поэтому среди них мы будем искать то, которое меньше В.сравниваем поразрядно С = 1001 1110 (число С из ответа 2) В = 1001 1111 С<B (число С из ответа 3) С = 1001 1111 В = 1001 1111 С=B (число С из ответа 4) С = 1101 1110 В = 1001 1111 С>B
alexderru
24.03.2020
Program mass;
uses crt;
var mas: array [1..5, 1..6] of integer; mas_od: array[1..6] of integer; i, j: integer;
begin randomize; for i := 1 to 5 do for j := 1 to 6 do mas[i, j] := random(10)-5;
for i := 1 to 5 do begin for j := 1 to 6 do write(mas[i, j]:4); writeln; end; writeln(''); for i := 1 to 5 do begin mas_od[i] := 1; for j := 1 to 6 do begin if((mas [i, j] mod 2 = 0) and (mas[i, j] > 0)) then mas_od[i] := mas_od[i] * mas[i, j]; end; end; for i:=1 to 6 do write(mas_od[i]:4); writeln; end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу к : сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при вложенный циклов pascal abc
var pk,vk,tk,x,k:integer;
begin
write('x = ');
readln(x);
for pk:= 1 to 6 do
begin
for vk:=1 to 6 do
begin
for tk:=1 to 6 do
if pk+vk+tk=x then
begin
writeln('pk = ',pk,' vk = ',vk,' tk = ',tk,' ',pk,' + ',vk,' + ',tk,' = ',pk+vk+tk);
k:=k+1
end
end
end;
writeln(k,' шансов')
end.