maryshecka
?>

Составьте программу, которая запрашивает стоимость 1 кг конфет и выводит на экран стоимость 0.1, 0.2, 0.3, 1 кг конфет. результат работыпрограммы может выглядеть так: введите стоимость 1 кг конфет: 7.6стоимость 0.1 кг конфет = 0.76 руб.стоимость 0.2 кг конфет = 1.52 руб.стоимость 0.3 кг конфет = 2.28 руб.язык программирования- pascal abc

Информатика

Ответы

vdnh451

Program candies;

var

i:integer;

c,d,m: real;

begin

write('Введите стоимость 1 кг конфет:');

readln(c);

d:=0.1;

for i:=1 to 10 do

begin

m := d*c;

writeln('Стоимость ',d,' кг конфет = ', m);

d:= d+0.1;

end;

end.

udalova-yelena

#include <iostream>

using namespace std;

int main()

{

 double x, y, z;   // объявления переменных для длин сторон

 bool b;           // логическая переменная, true - построить можно, false - построить нельзя

 setlocale(LC_ALL, "Russian");

 cout << "Введите длины сторон треугольника: ";

 cin >> x >> y >> z;         // ввод длин сторон

 b = false;                  // начальное значение для b

 if (x >= y && x >= z)       // если x самая длинная сторона треугольника

   b = x < y + z;            // проверяем, что длинная сторона меньше суммы двух других сторон, результат сохраняем в b

 else if (y >= x && y >= z)  // если y самая длинная сторона треугольника

   b = y < x + z;            // проверка та же

 else if (z >= x && z >= y)  // если z самая длинная сторона треугольника

   b = z < x + y;            // проверка та же

 if (b)                      // смотрим b и выводим соответствующее сообщение

   cout << "\nТреугольник построить можно\n";

 else

   cout << "\nТреугольник построить нельзя\n";

}

drozd2008

Объяснение:

С каждым днём технологии развиваются все больше, но у этого развития есть не только достоинства, но и недостатки. Например то, что сейчас узнать о человеке личную информацию через интернет не составит и труда, ведь он сам оставил ее там.

Информационная безопасность очень важна для участника современного общества. Преподаватели информационных дисциплин играют большую роль для просвещения темы информационной безопасности. Именно они могут людям обезопасить себя и своих близких от проблем и опасности, связанных с утечкой конфедкнциальной информации.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая запрашивает стоимость 1 кг конфет и выводит на экран стоимость 0.1, 0.2, 0.3, 1 кг конфет. результат работыпрограммы может выглядеть так: введите стоимость 1 кг конфет: 7.6стоимость 0.1 кг конфет = 0.76 руб.стоимость 0.2 кг конфет = 1.52 руб.стоимость 0.3 кг конфет = 2.28 руб.язык программирования- pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

сергей1246
Потапова 79275136869323
zharovaleks
test43
mmi15
Yelena_Irina826
озерская_Мария1234
Shurshilina850
Акимцева27
tanias
boykoz9
rimmaskis
katarinacorvus825
sancity997124