Леонард Эйлер (1707-1783) — математик, механик, физик и астроном. По происхождению швейцарец. Идеальный математик 18 века - так часто называют Эйлера.
Ученый необычайной широты интересов и творческой продуктивности. Автор свыше 800 работ по математическому анализу, дифференциальной геометрии, теории чисел, приближенным вычислениям, небесной механике, математической физике, оптике, баллистике, кораблестроению, теории музыки и других, оказавших значительное влияние на развитие науки. За время существования Академии наук в России, считается одним из самых знаменитых ее членов.
var i,n,sum:integer;
begin
randomize;
for i:=1 to 60 do begin
if (random(100)+1)>5 then begin
sum:=sum+random(201)+150;
end;
end;
if sum>=12000 then writeln('plan vipolnen') else writeln('plan ne vipolnen');
end.
var i,j,neud:integer;
begin
randomize;
for i:=1 to 20 do begin
for j:=1 to 5 do begin
if random(10)=0 then begin neud:=neud+1; break; end;
end;
end;
writeln('neud - ',neud,' udv - ',20-neud);
end.
var i,j,reis:integer; mon:real;
begin
randomize;
for i:=1 to 25 do begin
reis:=random(3)+8;
if random(100)>3 then begin
for j:=1 to reis do begin
mon:=(random(91)+30)*2.8+mon;
end;
end;
end;
writeln(mon:5:0);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу: найти произведение чисел, оканчивающихся на 5, в промежутке от 1 до 100.
var s, i: int64;
begin
s:=5;
i:=15;
while (i<=100) do begin
s:=s*i;
i:=i+10;
end;
writeln(s);
end.