ЕленаАнастасия315
?>

Даны x, y, z. напишите программу для вычисления значения арифметического выражения

Информатика

Ответы

Plotnikovangav

Интерактивная программа - это компьютерная программа, для работы которой требуется взаимодействие с пользователем. Это взаимодействие может включать в себя ввод информации, изменение информации, управление информацией или иное манипулирование данными. Большинство программ являются интерактивными.

Примером таких программ может быть «Логика для малышей»,Baby Logics, Cifiri, «Развиваем память», Монтессори, "Веселые Картинки" — инструментальный пакет для создания и решения задач, связанных со сборкой на экране упорядоченного множества объектов текстовой и графической структуры и т. д.

Belokonev286

#include <iostream>

#include<vector>

using namespace std;

int square(int x){

for (int i = 1; i <= 45; ++i){

if (i * i <= x){

continue;

}

return (i - 1) * (i - 1);

}

}

int main()

{

int x, y, xwas, ywas, xywas;

cin >> x >> y;

xwas = square(x);

ywas = square(y);

xywas = square(x + y);

if (xwas + ywas < xywas){

cout << "Petya gives paint to Vasya";

}

else if (xwas + ywas == xywas){

cout << "Equal";

}

else {

cout << "Petya leaves paint to himself";

}

return 0;

}#include <iostream>

#include<vector>

using namespace std;

int square(int x){

for (int i = 1; i <= 45; ++i){

if (i * i <= x){

continue;

}

return (i - 1) * (i - 1);

}

}

int main()

{

int x, y, xwas, ywas, xywas;

cin >> x >> y;

xwas = square(x);

ywas = square(y);

xywas = square(x + y);

if (xwas + ywas < xywas){

cout << "Petya gives paint to Vasya";

}

else if (xwas + ywas == xywas){

cout << "Equal";

}

else {

cout << "Petya leaves paint to himself";

}

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны x, y, z. напишите программу для вычисления значения арифметического выражения
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайлович_гергиевич315
shugayzhanna6
Sergei1198
Asplaksina
ShALIGINA
teregorka1977205
ilyanedelev
zsv073625
Васильев1028
Кристина Валентиновна
Belik-elena20111
alexander4590
manu95957
Melsan19914239
Александровна