krasnobaevdj3
?>

44) в корзине лежит a красных и b синих шаров. из корзины наугад вынимают n шаров. требовалось написать программу, которая определяет количество вариантов такого опыта (вариантом считаем пару чисел: количество вынутых красных и синих шаров программист торопился и написал программу неправильно: var n, a, b: integer; readln(n, a, b); if a + b < n then writeln(0) if a < b then if a < n then writeln(a+1) if b < n then writeln(b+1) else writeln(n+1); последовательно выполните следующее: 1. определите, что выведет программа при n = 5, a = 3, b = 6. 2. укажите значения n, a, b, при которых программа выдаёт неправильный ответ. 3. укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы.

Информатика

Ответы

borisovaks496

#include <iostream>

#include <string>

bool is_palindrome(const std::string& s) {

   std::string r(s);

   std::reverse(r.begin(), r.end());

   return s == r;

}

int main() {

   std::string s1,s2;

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите число 1: ";

   std::getline(std::cin, s1);

   std::cout << "Введите число 2: ";

   std::getline(std::cin, s2);

   if (is_palindrome(s1)|| is_palindrome(s2))

       std::cout << "Одно из введенных чисел является палиндромом " << std::endl;

   else

       std::cout << "Ни одно из введенных чисел не является палиндромом " << std::endl;

   return 0;

}

Gennadevna-Darya1216

• наименование – это название трехмерного объекта (эскиза, операции, вс плоскости, детали, сборки и пр.). Наименование, которое система присваивает автоматически (например, Эскиз:1, Операция вращения:2), пользователь может изменить, обозначив принадлежность или назначение трехмерного элемента в модели. Наименование отображается в дереве построения модели возле значка каждой операции или элемента;

• видимость – это свойство управляет отображением трехмерного объекта в документе (скрытый или видимый). Переключение с невидимого на видимый режим осуществляется с команд контекстного меню дерева построения: Показать и Скрыть соответственно;

• состояние – любой объект может быть включен или исключен из расчета. При исключенном из расчета элементе модель перестраивается так, как будто этого элемента вообще нет. Для управления состоянием также применяются команды контекстного меню дерева построения: Включить в расчет и Исключить из расчета;

• цвет – задает цвет объекта в модели. Это свойство недоступно только для значка начала системы координат, каждая стрелка которого имеет свой предустановленный цвет (ось X – красный, ось Y – зеленый, ось Z – синий). Цвет трехмерного объекта выбирается из раскрывающегося списка Цвет на вкладке Свойства панели свойств при создании каждого объекта. Если представленные в списке цвета вас не устраивают (в нем всего 40 цветов), вы можете воспользоваться стандартным диалоговым окном выбора цвета операционной системы Windows, в котором указать произвольный цвет. При задании цвета объекта вы также можете установить флажок Использовать цвет детали, в результате чего объект будет иметь тот же цвет, который задан для всей детали.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

44) в корзине лежит a красных и b синих шаров. из корзины наугад вынимают n шаров. требовалось написать программу, которая определяет количество вариантов такого опыта (вариантом считаем пару чисел: количество вынутых красных и синих шаров программист торопился и написал программу неправильно: var n, a, b: integer; readln(n, a, b); if a + b < n then writeln(0) if a < b then if a < n then writeln(a+1) if b < n then writeln(b+1) else writeln(n+1); последовательно выполните следующее: 1. определите, что выведет программа при n = 5, a = 3, b = 6. 2. укажите значения n, a, b, при которых программа выдаёт неправильный ответ. 3. укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

klykovav672
monenko
abrolchik8511
spz03
maksmi
yurovolga
Reznikova1075
kyzua2475
Андреевич
filantropagv4
bellenru
fedotochkin8
Igorevich1512
mgrunova
elena-ppk