Dmitrievna405
?>

1.даны целые числа a, b, c. написать программу, подсчитывающую количество нечетных чисел среди данных2.даны целые числа a, b, c. написать программу, подсчитывающую количество положительных и количество отрицательных чисел среди данных ​

Информатика

Ответы

uchpaot

JavaScript (EcmaScript2015):

1)

let k = 0;

let [a,b,c] = prompt('Введите три целых числа через пробел.').split(' ');

if (a % 2 != 0) k++;

if (b % 2 != 0) k++;

if (c % 2 != 0) k++;

alert('Кол-во нечётных: ' + k);

2)

let O = 0;

let P = 0;

let [a,b,c] = prompt('Введите три целых числа через пробел.').split(' ');

if (a < 0) O++

else if (a > 0) P++;

if (b < 0) O++

else if (b > 0) P++;

if (c < 0) O++

else if (c > 0) P++;

alert('Кол-во отрицательных: ' + O);

alert('Кол-во положительных: ' + P);

palosik7621
Program Pas02;
uses Crt;
const
  n=20;
var
  a:array[1..n] of real;
  i,k:integer;
  t:real;
begin
  Randomize;
  ClrScr;
  Writeln('Массив случайных чисел');
  k:=0;
  for i:=1 to n do begin
    a[i]:=Random(31)-15.0;
    Write(a[i]:6:1);
    if a[i]=10.0 then Inc(k)
    end;
  Writeln;
  Writeln('Количество элементов, равных 10: ',k);
  Write('Нулевые элементы ');
  k:=0;
  for i:=1 to n do
    if a[i]=0 then begin Inc(k); Write(i,' ') end;
  if k=0 then Writeln('отсутствуют') else Writeln;
  Writeln('Меняем местами элементы 3 и 6');
  t:=a[3];
  a[3]:=a[6];
  a[6]:=t;
  for i:=1 to n do
    Write(a[i]:6:1);
  Writeln
end.

Тестовое решение
Массив случайных чисел
   2.0 -12.0   8.0  -2.0  -1.0   3.0 -12.0  -9.0   3.0   9.0  -8.0   0.0  -7.0  -4.0 -12.0  10.0   9.0   5.0  -8.0   6.0
Количество элементов, равных 10: 1
Нулевые элементы 12
Меняем местами элементы 3 и 6
   2.0 -12.0   3.0  -2.0  -1.0   8.0 -12.0  -9.0   3.0   9.0  -8.0   0.0  -7.0  -4.0 -12.0  10.0   9.0   5.0  -8.0   6.0
edvlwork15
Program Pascal1;
uses Crt;
const
  m=4;
  n=2;
var
  a:array[1..m,1..n] of real;
  i,j,k:integer;
begin
  ClrScr;
  Randomize;
  Writeln('Сформированный масcив');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(31)-15.0;
      Write(a[i,j]:6:1);
      if a[i,j]=10 then Inc(k)
      end;
    Writeln
  end;
  Writeln('Количество элементов, равных 10: ',k);
  Write('Нулевые элементы: ');
  for i:=1 to m do
    for j:=1 to n do
      if a[i,j]=0 then Write('a[',i,',',j,'] ');
  Writeln
end.

Вариант выполнения:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.даны целые числа a, b, c. написать программу, подсчитывающую количество нечетных чисел среди данных2.даны целые числа a, b, c. написать программу, подсчитывающую количество положительных и количество отрицательных чисел среди данных ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nikolai172
chermen40
Давид-Ольга
restkof
anazarov80
Aleksandrovich-Yurevna1421
katarinacorvus825
aamer9992680
ЕВ1873
ikhilovb76
YuREVICh646
lovel24
fucksyara
uksusoval617