irinasolodova3
?>

Написать программу и блок-схему к : дано число. если оно отрицательное, тогда возвести число в квадрат. а если нет - возвести в третью степень.

Информатика

Ответы

frame45
var  N: integer; begin  Readln(N);  if N < 0 then    N := N * N  else    N := N * N * N;  Writeln(N); end.
Написать программу и блок-схему к : дано число. если оно отрицательное, тогда возвести число в квадр
menesmir

количество цветов в палитре определяется формулой хартли:

n=2^i (где n - количество цветов,   i - "вес" 1 px в битах).

1. найдем количество пикселей в изображении: 256*256=2^8 * 2^8 = 2^16 px

2. определим "вес" всех рх, переведя кб в биты: 8*2^13 (бит) = 2^3 * 2^13 = 2^16 (бит)

3. разделим "вес" всего изображения на количество рх (то есть найдем "вес" 1 рх в битах): 1 рх = 2^16 / 2^16 = 1 бит

4. следовательно (см. начало), количество цветов n=2^1=2 (т.е. изображение двухцветное, скорее всего - ч/б.

Dragun1684
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
function
Transpose(a: array[,] of integer): array[,] of integer;
//Поворот на 90гр по часовой стрелке
begin
  var m := Length(a, 0);
  var n := Length(a, 1);
  Result := new integer[n, m];
  for var i := 0 to n-1 do begin
    for var j := 0 to m-1 do
      Result[i, j] := a[m-1-j, i];
  end;
end;

begin
  var n := ReadInteger('Введите n:');
//Заполнение матрицы NxN сл. числами и вывод на экран
  var a :=MatrixRandom(n, n);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(a[i,j]);
    println;
    end;
     println;

  Println('поворот влево на 90 гр');
  var b := Transpose(a);
  b:=Transpose(b);
  b:=Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
  println;

  Println('поворот вправо на 90гр');
  b := Transpose(a);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
 println;

 Println('поворот на 180 гр');
  b := Transpose(a);
  b := Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу и блок-схему к : дано число. если оно отрицательное, тогда возвести число в квадрат. а если нет - возвести в третью степень.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ea-office
mrvasilev2012
olgusikok
Bmashutav16
kotsur
федороа
Казаков
Olesyamilenina8
Nazart44446
Dmitrii_Shamilevich2019
znaberd786
bufetkonfet53
aeykin
BogdanR106203
Гаврилаш