femida69
?>

Даны три целых числа z, y, x. составьте программу вычисления выражения (z+y3) /x+z. программа по инфе

Информатика

Ответы

lsyrbu

var

 z, y, x: Integer;

begin

 Write ('Введите целые числа z, y, x: ');

 ReadLn (z, y, x);

 Writeln ('Результат = ', (z + y * 3) / (x + z));

 ReadLn;

end.

volna22051964
Var mas: array[1..15] of integer;
      i, min, max, nMin, nMax:integer;
begin
  writeln('Введите 15 элементов массива');
  for i := 1 to 15 do
    readln(mas[i]);
    min := mas[1];
    max := mas[1];
    nMin := 1;
    nMax := 1;
  for i := 1 to 15 do
    begin
      if max < mas[i] then
        begin
          max := mas[i];
          nMax := i;
         end;
      if min > mas[i] then
        begin
          min := mas[i];
          nMin := i;
        end;
    end;
  writeln('Максимальное число и его номер ', max, '   ', nMax, ' Минимальное число и его номер ', min, '   ', nMin);
end.
poiskmarina
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Range(100,999).Where(n->IsPrime(n)).Println(',')
end.

Результат
101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431,433,439,443,449,457,461,463,467,479,487,491,499,503,509,521,523,541,547,557,563,569,571,577,587,593,599,601,607,613,617,619,631,641,643,647,653,659,661,673,677,683,691,701,709,719,727,733,739,743,751,757,761,769,773,787,797,809,811,821,823,827,829,839,853,857,859,863,877,881,883,887,907,911,919,929,937,941,947,953,967,971,977,983,991,997

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три целых числа z, y, x. составьте программу вычисления выражения (z+y3) /x+z. программа по инфе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nadezhdasvirina
Mnatsovna
Shumnova42
assistant
gulsinatahckeeva
natalyaionova
Aleksei
cmdkotelniki
mishink535
Vladislav98
Шитенков
mixtabak2
Radikovnanikolaeva
echervyakov
annakuzina2023