TOKAREVA Stepan
?>

Решить: напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 ( 0- признак окончания ввода не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел кратных 5 или 9. ​

Информатика

Ответы

dashafox8739

я вроде уже решал такую задачу... Ту в условиях только добавилась фраза "по модулю". Скорректировал программу с учетом уточнения в задании.

var

   a, n, i : integer;

begin

   repeat

       read(a);

       if (abs(a) <= 30000) and (a <> 0) then begin

           if (a mod 5 = 0) or (a mod 9 = 0) then n += 1;

           i += 1;

       end;

   until (a = 0) or (i = 1000);

   writeln(n);

end.

АлександровнаВладлен243
Я ответил, но ответ почему-то не сохранился.
1) Минимально в компьютер входят: системный блок, клавиатура и монитор.
Мышь, принтер и сканер не входят! Во времена MS-DOS работали без мышей, принтер подключали редко, а сканеров тогда вообще не было.

2) В системный блок входят материнская плата, на ней процессор, память, микросхема BIOS. В слоты вставляются видеокарта и звуковая карта.
Хотя в последнее время видео и звук ставят сразу на материнскую плату, но они обычно плохого качества, нормальные нужно ставить в слоты отдельно.
На шлейфах подключаются винчестер и CD/DVD дисковод.
Иногда Blue-Ray, но это пока редкость. Раньше еще были дисководы для дискет, 5,25 дюймов и 3,5 дюйма, последние еще иногда встречаются.
В сервере даже видеокарта и монитор не нужны.

3) Контроллер - это микросхема, плата или даже программа, которая управляет какой-то периферией, например, видео, звуком или сканером.

4) Физически устройства соединяются через слоты, раньше были ISA и VLB, сейчас PCI, PCI-Express, SCSI и другие.
А также через шлейфы или просто по проводам.

5) Информация по шине попадает на нужное устройство благодаря шине адреса, в которой заложено, куда эта информация должна прийти.
nairahay
Я ответил, но ответ почему-то не сохранился.
1) Минимально в компьютер входят: системный блок, клавиатура и монитор.
Мышь, принтер и сканер не входят! Во времена MS-DOS работали без мышей, принтер подключали редко, а сканеров тогда вообще не было.

2) В системный блок входят материнская плата, на ней процессор, память, микросхема BIOS. В слоты вставляются видеокарта и звуковая карта.
Хотя в последнее время видео и звук ставят сразу на материнскую плату, но они обычно плохого качества, нормальные нужно ставить в слоты отдельно.
На шлейфах подключаются винчестер и CD/DVD дисковод.
Иногда Blue-Ray, но это пока редкость. Раньше еще были дисководы для дискет, 5,25 дюймов и 3,5 дюйма, последние еще иногда встречаются.
В сервере даже видеокарта и монитор не нужны.

3) Контроллер - это микросхема, плата или даже программа, которая управляет какой-то периферией, например, видео, звуком или сканером.

4) Физически устройства соединяются через слоты, раньше были ISA и VLB, сейчас PCI, PCI-Express, SCSI и другие.
А также через шлейфы или просто по проводам.

5) Информация по шине попадает на нужное устройство благодаря шине адреса, в которой заложено, куда эта информация должна прийти.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить: напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 ( 0- признак окончания ввода не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел кратных 5 или 9. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Анатольевич-Митюшин
saniopt
О. Карпов1691
al2nik2ol
nord248
cvetprint
VSpivak3122
Mikhail_Magomed635
Dmitrychekov9
kogakinoa
bd201188
innaterenina
steger
fedoseevalyubov
Нина1449