aa276568
?>

Python.: программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и определить значение наибольшего элемента последовательности. числа, следующие за числом 0, считывать не нужно. напишите код

Информатика

Ответы

anatolevich1931

def f():

   numbers = []

   while True:

       num = int(input())

       if num == 0:

           break

       numbers.append(num)

   return max(numbers)

Vova220
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
akakne86

cd ~

mkdir folder1

cd folder1

touch file1

touch file2

touch file3

touch file4

tar cvf archive.tar *

mkdir ../folder2

cd ../folder2

touch new_file

cp ../folder1/archive.tar .

tar rvf archive.tar new_file

tar vf archive.tar --delete file3

tar vf archive.tar --list > list1

tar vf ../folder1/archive.tar --list > list2

diff list1 list2

#Разъединение выполнить не получится, потому что все файлы пустые, но если засовывать не пустые, то

split -b 10M archive.tar "part" # вместо 10M нужный размер

cat part* > joined_archive.tar

tar vf archive.tar --list

tar vf joined_archive.tar --list

tar czvf final_archive.tar archive.tar ../folder1/archive.tar joined_archive.tar

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python.: программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и определить значение наибольшего элемента последовательности. числа, следующие за числом 0, считывать не нужно. напишите код
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

АлексейГагиковна1774
martinzdraste
minasov19
aniramix
alexkortyukov
milenaochirova01017424
Александр1991
starh
dariagromova54
eshabunina
ElenaEgorova1988576
AleksandrIvanovich1273
sanhimki47
Надежда-Алексеевна82
Nikolaevna Malika1511