Исаченко Тераски1181
?>

Решить это в с++ абай и айбар любят массивы. недавно у абая был день рождения, поэтому айбар подарил абаю много подарков, в том числе массив. они сразу же начали играть с ним и абай придумал такую игру: нужно посчитать количество подотрезков массива, у которых количество различных чисел не больше k. подотрезком называется часть массива, которая может быть получена удалением некоторого (возможно нулевого) количества элементов с начала и с конца массива. айбар успешно справился с этой , а сможете ли справиться вы? формат входных данных в первой строке входных данных заданы 2 целых числа n и k (1 ⩽ n ⩽ 106 , 0 ⩽ k ⩽ n во второй строке задан массив a из n целых неотрицательных чисел (0 ⩽ ai ⩽ 109 ). формат выходных данных в единственной строке выведите число - ответ на . пример стандартный ввод стандартный вывод 10 3 1 5 2 1 5 3 4 1 1 5 32

Информатика

Ответы

dima8585

#include <iostream>

#include <cmath>

int main()

{

 float x1, y1, x2, y2;

 std::cout << "x1 :" << std::endl;

 std::cin >> x1;

 std::cout << "y1 :" << std::endl;

 std::cin >> y1 ;  

 std::cout << "x2 :" << std::endl;

 std::cin >> x2;  

 std::cout << "y2 :" << std::endl;

 std::cin >> y2;  

 float result = std::sqrt((std::pow(std::abs(x1-x2), 2) + std::pow(std::abs(y1-y2), 2)));

 std::cout << result << std::endl;

 char * temp = new char[0]();  

 std::cin >> temp;

 return 0;

}

Gennadievna bessonov
Компью́терная гра́фика (также маши́нная графика) — область деятельности, в которой компьютеры наряду со специальным программным обеспечением используются в качестве инструмента, как для создания (синтеза) и редактирования изображений, так и для оцифровки визуальной информации, полученной из реального мира, с целью дальнейшей её обработки и хранения.

История Править

Первые вычислительные машины не имели отдельных средств для работы с графикой, однако уже использовались для получения и обработки изображений. Программируя память первых электронных машин, построенную на основе матрицы ламп, можно было получать узоры.

В 1950 году в военном компьютере Whirlwind-I (на русс. Вихрь), встроенный в систему SAGE противовоздушной обороны США, впервые был применён монитор — как средство отображения визуальной и графической информации.[источник не указан 415 дней]

В 1957 году Рассел Кирш создал первый сканер для компьютера и получил на нём первое цифровое изображение — маленького сына Владлена.[источник не указан 415 дней]

В 1961 году программист С. Рассел возглавил проект по созданию первой компьютерной игры с графикой. Создание игры («Spacewar!») заняло около 200 человеко-часов. Игра была создана на машине PDP-1.

В 1963 году Эдвард Зейджек (Edward E. Zajac), программист из Bell Labs, сделал первую компьютерную анимацию - движение спутника вокруг Земли. Анимация демонстрировала теоретический спутник, который использовал гироскопы, чтобы поддерживать свою ориентацию относительно Земли. Вся компьютерная обработка была сделана на компьютерах IBM серий 7090 или 7094 с использование программы ORBIT.[источник не указан 24 дня]

В 1963 году американский учёный Айвен Сазерленд создал программно-аппаратный комплекс Sketchpad, который позволял рисовать точки, линии и окружности на трубке цифровым пером. Поддерживались базовые действия с примитивами: перемещение, копирование и др. По сути, это был первый векторный редактор, реализованный на компьютере. Также программу можно назвать первым графическим интерфейсом, причём она являлась таковой ещё до появления самого термина. Айвен Сазерленд также в 1966 и 1968 годах создал первые компьютерные стереоскопические очки и шлем виртуальной реальности.

В середине 1960-х гг. появились разработки в промышленных приложениях компьютерной графики. Так, под руководством Т. Мофетта и Н. Тейлора фирма Itek разработала цифровую электронную чертёжную машину. В 1964 году General Motors представила систему автоматизированного проектирования DAC-1, разработанную совместно с IBM.

В 1964 году Эдвард Зейджек создал первую компьютерную анимацию — движение спутника вокруг земли.

В 1968 году[1] группой под руководством Н. Н. Константинова была создана компьютерная математическая модель движения кошки. Машина БЭСМ-4, выполняя написанную программу решения дифференциальных уравнений, рисовала мультфильм «Кошечка»[2], который для своего времени являлся прорывом. Для визуализации использовался алфавитно-цифровой принтер.

В 1968 году[источник не указан 1822 дня] существенный прогресс компьютерная графика испытала с появлением возможности запоминать изображения и выводить их на компьютерном дисплее, электронно-лучевой трубке.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить это в с++ абай и айбар любят массивы. недавно у абая был день рождения, поэтому айбар подарил абаю много подарков, в том числе массив. они сразу же начали играть с ним и абай придумал такую игру: нужно посчитать количество подотрезков массива, у которых количество различных чисел не больше k. подотрезком называется часть массива, которая может быть получена удалением некоторого (возможно нулевого) количества элементов с начала и с конца массива. айбар успешно справился с этой , а сможете ли справиться вы? формат входных данных в первой строке входных данных заданы 2 целых числа n и k (1 ⩽ n ⩽ 106 , 0 ⩽ k ⩽ n во второй строке задан массив a из n целых неотрицательных чисел (0 ⩽ ai ⩽ 109 ). формат выходных данных в единственной строке выведите число - ответ на . пример стандартный ввод стандартный вывод 10 3 1 5 2 1 5 3 4 1 1 5 32
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mvv-155
olesyashazk5055
fudan
zubritskiy550
dilbaryan76
ASRodichev
Goldaram84
Воздвиженская
Faed_Arakcheeva
ustinov434
serkinn69
reinish23
annarom1306
mahalama7359
Vladimirovich Aleksandr1889