krasnova1977
?>

Составьте программу которая запрашивает число x и определяет чётное или не чётное это число

Информатика

Ответы

иванович Диденко1524

program oddeven;

var a:integer;

begin

 writeln('Введите число');

 readln(a);

 if a mod 2 = 0 then

   writeln('Число чётное')

 else

   writeln('Число нечётное');

end.

Alekseevich_Viktorovna

Сноска — примечание (замечание), помещаемое внизу полосы (постраничная сноска) или в конце текста (концевая сноска). Другое определение это текст, помещаемый внизу страницы, под чертой, отделяющей его от основного текста...

Гиперссылка (англ. hyperlink) — часть гипертекстового документа, ссылающаяся на другой элемент (команда, текст, заголовок, примечание, изображение) в самом документе, на другой объект (файл, каталог, приложение), расположенный на локальном диске или в компьютерной сети, либо на элементы этого объекта.

Объяснение:

Viktorovich

1.

1) 4*24*1000*16 ≈ 3*2^19 (бит/с)

2) 900 Мбайт=9*25*4*2^23 бит =9*25*2^25 бит

3) (9*25*2^25) / (3*2^19) = 3*25*2^6 (c) = 75*64 (c) =75*64/60 (мин)= 80(мин)                                

ответ  80 мин

2.

1)  640*480=(5*2^7)*(15*2^5)=5*15*2^12 пикселей

2) 240 Кбайт=15*2^4 *2^13 бит=15*2^17 бит

3) (15*2^17) / (5*15*2^13) = 2^4 / 5  бит =3,2 бит = 3 бит - 1 пиксель

4) 2^3=8 цветов                ответ 8 цветов

3.

1) 80 *0,7=56 Мбайт - cжатый файл

 80 Мбайт =5*2^4 *2^23 бит=5*2^27 бит

  56 Мбайт=7*2^26 бит

2)  5*2^27 / 2^22 = 5*2^5 (с) = 160 секунд - время несжатого файла

3)  7*2^26 / 2^22 =7*2^4 (c) = 112 (c)

4) 23(c)+12(c)+112(c)= 147 (c) - время сжатого файла

5) 160-147=13 (с)    ответ передача сжатого файла быстрее на 13 с

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая запрашивает число x и определяет чётное или не чётное это число
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osirparts7854
Дмитрий_Пергамент669
Litvin_Ivanov
jaksonj326
Yurevna_Kharkchinov1302
fucksyara
palchiknr
zvanton
e90969692976
Aleksandr362
Olybetezina1973
burtsev3339
Витальевна
sisychev
Korinchan390