алексеевич810
?>

Написать программу которая вычисляет переменную c по формуле : c = 7(a-b) +3a/4a и выводит на экран, если a=6, b=4.​

Информатика

Ответы

movlam11

var

   a : integer := 6;

   b : integer := 4;

   c : real;

begin

   c := 7*(a-b)+3*a/(4*a);

   writeln(c);

end.

Fedorovich_Aleksandrovich685
//Pascal ABC.NET v3.1 сборка 1172

Var
 f,s:text;
 st,sp:string;
 i:integer;
 c:char;
begin
 assign(s,'text1.txt');
 reset(s);
 while not Eof(s) do
 begin;
 readln(s,sp);
 st:=st+sp+chr(10)+chr(13);
 end;
 close(s);
 for i:=1 to length(st) div 2 do
  begin
   c:=st[i];
   st[i]:=st[length(st)-i+1];
   st[length(st)-i+1]:=c;
  end;
 assign(f,'text.txt');
 rewrite(f);
 write(f,st);
 close(f);
end.

Текст в файле text1.txt:

Simple text
1And another simple text
2New text

Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS
Elizavetaborisovna1992
№1.
Тысячи путей ведут к заблуждению, к истине - только один.
Для начала надо посчитать, сколько всего символов в данном предложении, следует считать знаки препинания и пробелы. 
Посчитав все знаки (Итого:57), мы получаем, что вес предложения 57 байт, переводим в биты, то есть умножаем на 8 (1 байт = 8 бит):
57*8=456.

№2.
Кодировка Unicode - это кодировка, каждый символ которой весит 16 бит. Итак, я посчитала количество знаков в предложении (Итого:32). Дальше: 16*32=512 бит.

№3.
Итак, мы видим, что из 16-битной кодировки получилась 8-битная, а это значит, что она уменьшилась вдвое.
8x=800
x=100 (у тебя ошибка, я посмотрела аналогичные задания, отличающиеся только значениями)

№4 допишу в комментарии.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая вычисляет переменную c по формуле : c = 7(a-b) +3a/4a и выводит на экран, если a=6, b=4.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bel1-79
andrey00713
ulyana-d
s777tver109
korotaeva778898
Хабарьева Андрей1056
нужен ответ по какой формуле делать (?)
julkamysh9
vladimir152
mikhisakov2017
Burov1446
aetolstih
Nataliya Aleksandr1197
rvvrps
Калмыкова-Петрунина
goldglobustour725