mnn99
?>

Составить программу перевода информационной ленты из начального состояния в конечное. положение каретки выделено. работу машины представить в виде таблицы. (машина поста) 1111 1 110101 - дано 000000010 1 0 - должно получится положение каретки выделено пробелами

Информатика

Ответы

vardartem876
Таблицы позволяют объединить однотипные данные в более-менее читабельную структуру, чего не делает словесное описание (как, например, приятней читать таблицу с датами и описанием исторических событий в таблице, чем читать словесную демагогию в учебиках). Таблицы позволяют ужать данные в размере, читателю сосредоточиться на главном. Они позволяют операторам обрабатывать её без каких-либо затруднений.

Еще пример: магазинные чеки. Не будет же машина (из-за технической сложности) или человек (из-за лени) писать на чеке: "продано столько-то столько-то того-то того-то ... пакет апельсинов весил шестьсот пядесят три грамма ... итд". На чеке будет табличка, где четко и точно будет написано то, что человек приобрел.
Вот. Так что табличные модели, несомненно, лучше словесных.
yanagitsina
uses crt;
var a, b, c, i, n, j :integer;   
s :array[1..10000] of integer;
begin
      clrscr;
      writeln('Введите размер массива');
      read(n);
      for i:=1 to n do 
          begin 
          s[i]:=random(46)-15; 
          writeln ('s[', i,']=', s[i]); 
          end;
      a:=s[1];for i:=1 to n do 
          if s[i]>a then 
              begin 
              a:=s[i]; 
              b:=i; 
              end;
      writeln ('Наибольший элемент s[', b, ']=',a);
end.

P.S. Надеюсь на благодарность и лучший ответ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу перевода информационной ленты из начального состояния в конечное. положение каретки выделено. работу машины представить в виде таблицы. (машина поста) 1111 1 110101 - дано 000000010 1 0 - должно получится положение каретки выделено пробелами
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tyukalova
annarom1306
Качкова1820
vyborovvs
Кириллов57
Oslopova
Галстян874
Yevgenii_Gurtovaya1532
Marina281
iv1as2
bondarev05071962
ariyskayaa5
Dmitrievich1871
Усошина1059
sport2293032