1.
program z1;
var a:array [1..10] of integer;
i,k:integer;
begin
write ('Введите элементы массива через пробел и нажмите Enter ');
for i:=1 to 10 do read (a[i]);
write ('Массив: ');
for i:=1 to 10 do write (a[i],' ');
writeln;
write ('Номера элементов больше 5: ');
for i:=1 to 10 do if a[i] > 5 then
begin
write (i,' ');
k:=k+1
end;
writeln;
writeln ('Элементов больше 5: ',k)
end.
2.
program z2;
var s:string;
begin
readln (s);
while pos('о',s)<>0 do delete(s,pos('о',s),1);
writeln(s)
end.
Объяснение:
Смотри картинки
2. Программа удаляет только строчные русские о
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу , которая получает 3 целых числа и находит количество чисел, кратно 5 язык - paskal
Как-то так:
var a,b,c,s:integer;
begin write('введите первое число - ');readln(a);
write('введите второе число - ');readln(b);
write('введите третье число - ');readln(c);
if (a mod 5 = 0)
then s = s + 1;
if (b mod 5 = 0)
then s = s + 1;
if (c mod 5 = 0)
then s = s + 1;
write ('кол-во чисел, кратных 5-ти - ', s);
end.