manu95957
?>

1. вывести все четные числа начиная с числа n до числа m. числа n и m задает пользователь. напишите программу паскале, .

Информатика

Ответы

Цветкова

Program n_1;

var n, m, i:integer;

begin

   read (n, m);

   for i:=n to m do if i mod 2 = 0 then write(i, ' ');

end.

Anatolevich667
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
Veronika343
Расстояние от точки до начала координат находится как длина гипотенузы прямоугольного треугольника, катетами которого являются координаты точки. Поскольку нам нужны не сами расстояния, а лишь сравнить их, то можно сравнивать квадраты, чтобы не извлекать корня.r_i^2=x_i^2+y_i^2

// PascalABC.NET 3.0, сборка 1088
var
  x1,x2,y1,y2,r1,r2:real;
begin
  Write('Введите координаты первой точки: '); Read(x1,y1);
  Write('Введите координаты второй точки: '); Read(x2,y2);
  r1:=sqr(x1)+sqr(y1); r2:=sqr(x2)+sqr(y2);
  if r1>r2 then Writeln('Ближе вторая точка')
  else
    if r1<r2 then Writeln('Ближе первая точка')
    else Writeln('Точки равноудалены')
end.

Тестовое решение:
Введите координаты первой точки: 16.3 -11.7
Введите координаты второй точки: 15.8 12
Ближе вторая точка

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. вывести все четные числа начиная с числа n до числа m. числа n и m задает пользователь. напишите программу паскале, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Андреевна
olg14855767
kokukhin
kurlasku
saveskul84
novkatrina
Donleksa2016
fucingprinces30
Kazantsevv_kostya
ainred
Aleksandrovna370
skorpion7228528
MikhailovichKrizhnaya578
Silaev988
Aksinya1036