vikashop269
?>

Напишите программу на c++, которая проверяет пользователя на знание таблицы умножения. пользователь сам вводит два целых однозначных числа. программа должна задать вопрос («каков результат умножения первого числа на второе» пользователь должен ввести ответ и увидеть на экране правильно он ответил или нет. если нет – ещё и показать верный результат.

Информатика

Ответы

gorbunova188

#include <iostream>

using namespace std;

int main(){

int a,b,z;

cin >> a >> b;

cout << "Каков результат умножения первого числа на второе?"

cin>> z;

if (a*b==z) cout << "Правильно!";

else cout << "Неправильно!\n Правильный ответ: " << a * b;

return 0;

}

Aleksei368
Добрый день! Конечно, я помогу вам написать программу на C++, которая проверяет пользователя на знание таблицы умножения.

Вот пример кода для такой программы:

```cpp
#include
using namespace std;

int main() {
int num1, num2, answer, correctAnswer;

// Пользователь вводит первое число
cout << "Введите первое число (от 1 до 9): ";
cin >> num1;

// Пользователь вводит второе число
cout << "Введите второе число (от 1 до 9): ";
cin >> num2;

// Задаем вопрос пользователю
cout << "Каков результат умножения " << num1 << " на " << num2 << "? ";
cin >> answer;

// Вычисляем правильный ответ
correctAnswer = num1 * num2;

// Проверяем ответ пользователя
if (answer == correctAnswer) {
cout << "Правильный ответ!";
} else {
cout << "Неправильный ответ. Правильный результат: " << correctAnswer;
}

return 0;
}
```

Шаги программы:

1. Пользователю предлагается ввести первое число от 1 до 9.
2. Пользователю предлагается ввести второе число от 1 до 9.
3. Задается вопрос: "Каков результат умножения первого числа на второе?"
4. Пользователь вводит свой ответ.
5. Программа вычисляет правильный ответ, умножив первое число на второе.
6. Проверяется, правильно ли ответил пользователь.
7. Если пользователь ответил правильно, выводится сообщение "Правильный ответ!".
8. Если пользователь ответил неправильно, выводится сообщение "Неправильный ответ. Правильный результат: [верный ответ]".

Надеюсь, этот ответ полностью соответствует вашим ожиданиям! Если у вас возникнут дополнительные вопросы, не стесняйтесь их задавать.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на c++, которая проверяет пользователя на знание таблицы умножения. пользователь сам вводит два целых однозначных числа. программа должна задать вопрос («каков результат умножения первого числа на второе» пользователь должен ввести ответ и увидеть на экране правильно он ответил или нет. если нет – ещё и показать верный результат.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eobmankina
yuliasam
Prostofil200790
Anna572
Devaunka40
dpolkovnikov
stairov536
elenalukanova
smook0695
margusha1974
gallows-warlike-0z
shyroshka836103
Yurii537
Valerii276
Grishanin
▲