4.Операционная система — комплекс программ, обеспечивающий управление аппаратными средствами компьютера, организующий работу с файлами и выполнение прикладных программ, осуществляющий ввод и вывод данных.
5.Обмен данными между компьютером и различными периферийными устройствами (терминалами, принтерами, гибкими дисками, жесткими дисками и т. ...
Обеспечение системы организации и хранения файлов.
Загрузка программ в память и обеспечение их выполнения.
Организация диалога с пользователем.
6.извини, не знаю
надеюсь
Program n1;
Uses CRT;
Const n=15;
Var A: array[1..n] of integer; B: array[1..n] of integer;
i,k,max: integer;
begin
randomize;
clrscr;
Writeln('ishodny massiv');
For i:=1 to n do
begin
a[i]:=random(100);
a[i]:=a[i]-50;
write(a[i]:4);
end;
writeln;
writeln('polychenny massiv');
max:=0;
For i:=1 to n do
begin
b[i]:=-a[i];
write(b[i]:4);
If a[i]=b[i] then k:=k+1;
If (b[i]>0)and(b[i]>max) then max:=b[i];
If (b[i]<0)and(-b[i]>max) then max:=-b[i];
end;
writeln;
Writeln('Kolychestvo neizmenyvshihsa elementov=',k,', samyi bolshoy po modyly element raven =',max);
writeln
end.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая запрашивает у пользователя длину и ширину участка в метрах и выводит на экран площадь этого участка в кв. м. в языке паскаля
program Example;
var
a, b: Double;
begin
Write ('Введите длину и ширину участка: ');
ReadLn (a, b);
WriteLn ('Площадь = ', (a + b) * 2 :10 :2);
ReadLn;
end.