Поделитесь своими знаниями, ответьте на вопрос:
Нужно написать программу в python. , .в текстовом файле находятся записи о номерах телефонов. в каждой строке записана информация об одном абоненте: № телефона, фио, адрес. необходимо решить с использованием функций . для представления данных удобно использовать словари.1)напишите программу, которая осуществляет поиск абонента с заданным именем.2)в текстовом файле записан текст, в котором встречаются целые числа. известно, что числа отделены от окружающего текста хотя бы одним пробелом. напишите программу которая находит сумму всех встретившихся в тексте чисел.
program proga;
var st,st2:string;
i:Integer;
begin
writeln('Введите число');
readln(st);
for i:=1 to length(st) do begin
st2:=st[i];
write(st2,' ');
end;
end.
2 задача
program proga2;
var st,st2:string;
i,a:Integer;
begin
writeln('Введите возраст');
readln(a);
if a>120 then
writeln('Неверные данные');
if a=1 then
writeln(a,' год');
if (a>1) and (a<5) then
writeln(a,' года');
if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');
if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then
writeln(a,' лет');
if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');
if(a>104) and (a<110)then writeln(a,' лет');
end.