ss2911
?>

Python 3.7 напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводятся количество чисел (0 не считаем), минимальное и максимальное из введенных чисел, их сумму и среднее значение. заранее большое

Информатика

Ответы

Екатерина

{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}

var

min,max,a:real;

begin

  readln(a);

  min:=a;max:=a;

   while a<>0 do

       begin

            readln(a);

                if a>max then

                    max:=a;

                if a<min then

                     min:=a;

        end;

writeln('min: ',min,'  max: ',max);

end.

malgoblin2663

1)

var
a: array[1..20] of integer;
i, j, k: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('удалили элементы из одинаковых цифр включая однозначные');
i := 1;
k := 10;
while i <= k do
begin
if (abs(a[i]) < 10) or ((a[i] mod 10) = (a[i] div 10)) then
begin
if i = k then k := k - 1
else
begin
for j := i to k - 1 do a[j] := a[j + 1];
k := k - 1;
end;
end
else
i := i + 1;
end;
for i := 1 to k do
write(a[i]:4);
end.

2)

var
a: array[1..20] of integer;
i, j, k,n: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('введите k(не должно содержать 1)=');
readln(k);
writeln('вставляем k перед всеми элементами где есть цифра 1');
i := 1;
n := 10;
while i <= n do
begin
if (abs(a[i]) mod 10=1) or (abs(a[i]) div 10=1) then
begin
for j:=n+1 downto i+1 do a[j]:=a[j-1];
a[i]:=k;
n:=n+1;
i:=i+1;
end;
i := i + 1;
end;
for i := 1 to n do
write(a[i]:4);
end.

3)

var
a: array[1..10] of integer;
i, j, k: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('меняем местами три первых и три последних элемента');
for i:=1 to 3 do
begin
k:=a[i];
a[i]:=a[i+7];
a[i+7]:=k;
end;
for i := 1 to 10 do
write(a[i]:4);
end.

 

kitoova

1)

var
a: array[1..20] of integer;
i, j, k: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('удалили элементы из одинаковых цифр включая однозначные');
i := 1;
k := 10;
while i <= k do
begin
if (abs(a[i]) < 10) or ((a[i] mod 10) = (a[i] div 10)) then
begin
if i = k then k := k - 1
else
begin
for j := i to k - 1 do a[j] := a[j + 1];
k := k - 1;
end;
end
else
i := i + 1;
end;
for i := 1 to k do
write(a[i]:4);
end.

2)

var
a: array[1..20] of integer;
i, j, k,n: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('введите k(не должно содержать 1)=');
readln(k);
writeln('вставляем k перед всеми элементами где есть цифра 1');
i := 1;
n := 10;
while i <= n do
begin
if (abs(a[i]) mod 10=1) or (abs(a[i]) div 10=1) then
begin
for j:=n+1 downto i+1 do a[j]:=a[j-1];
a[i]:=k;
n:=n+1;
i:=i+1;
end;
i := i + 1;
end;
for i := 1 to n do
write(a[i]:4);
end.

3)

var
a: array[1..10] of integer;
i, j, k: integer;

begin
for i := 1 to 10 do
begin
a[i] := random(71) - 40;
write(a[i]:4);
end;
writeln;
writeln('меняем местами три первых и три последних элемента');
for i:=1 to 3 do
begin
k:=a[i];
a[i]:=a[i+7];
a[i+7]:=k;
end;
for i := 1 to 10 do
write(a[i]:4);
end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python 3.7 напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводятся количество чисел (0 не считаем), минимальное и максимальное из введенных чисел, их сумму и среднее значение. заранее большое
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kuz-vlad21
yaelenatu
yyyaga
Владислав1246
billl24
korchags19983941
slipu817838
autofilters27
yurassolo747
Bi-1704
murin
ГалинаРайгородская
YuRII1236
delfinmos
Alekseevna1811
▲