#include <iostream>
#include <vector>
using namespace std;
int am_dig(int k){
int res = 0;
while(k > 0){
res++;
k /= 10;
}
return res;
}
double average(vector<double> a){
double sum = 0;
for(auto i: a)
sum += i;
return sum/a.size();
}
int main() {
vector<double> a;
double x = 1;
while(x != 0){
cin >> x;
if(am_dig(x) == 3)
a.push_back(x);
}
if(a.size() == 0)
cout << "NO";
else
cout << average(a);
}
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу в python: последовательность состоит из целых чисел и завершается числом 0. выведите, наименьший элемент, а так же какое количество элементов этой последовательности равны ее наименьшему элементу. подсказка: обработайте первое число перед циклом. обработайте случай пустой последовательности (пользователь сразу ввел 0 в случае пустой последовательности правильный ответ: 0 0. не забывайте изменять счетчик количества минимальных объектов при изменении минимума. формат ввода последовательность целых чисел, каждое число на отдельной строчки. последовательность заканчивается 0. формат вывода минимальный элемент и число элементов, которые равны ему. числа разделите пробелом.
1)Монитор,(на счет магнитофона не уверен, сам по себе именно магнитофон никак не является устройством ПК, но если подразумевают пол этим словом динамик ПК, то подходит)
2)Получение
3)Электрический ток
4)Анатомический муляж
5)102 бита
6)48
7)из перечисленных ниже нет верного ответа. 568 в десятичной = 1 000 111 000 в двоичной.
8)АВИБА
9)Представленные ответы неправильны, так как не являются двоичным кодом(присутствуют двойки)+не указано к какой системе счисления принадлежит y (если x - очевидно 16-ти ричная, то y может быть как 16 так и 10
10) И снова нет верного ответа из предложенных, т.к. получится D8
11)800 бит
12) (Ячейки excel где?)
13) Аналогично 12
14)тоже
15)27
16)User-name
17)c*.c*
18)145.92.128.0
19)Верного ответа нет. Правильно: 22
20) 5
Объяснение: