Чему будет равно значение целой переменной < > после выполнения этого фрагмента программы? a: =10; for i: =1 to 3 do begin a: =a-2 end; с объяснением !
с каждым шагом цикла мы вычитаем двойку из исходного числа=> 10-2=8
8-2=6
6-2=4
Paradismebel
24.07.2020
Насчет дано решение не понял, дано и так есть, а решение без понятия честно, возможно есть формула или что-то вроде этого, но мне проще на взгляд определить что если точность измерения 0.1 значит количество измерений в 10 раз больше чем количество градусов, навскидку если брать диапазон -5..+50 то можно найти 56 значений включая 0,а значит около 560 уникальных значений, следовательно минимальное количество бит должно быть 10 ибо два в десятой 1024, в то время как два в девятой 512 слишком мало для данного случая
pavelvsk2023
24.07.2020
4 а) const n=10; var a:array[1..n] of integer; i,k:integer; begin writeln('Исходный массив: '); for i:=1 to n do begin a[i]:=random(10); write(' ',a[i]); end; writeln; for i:=1 to n do begin if ((i mod 2) = 0) then a[i]:=a[i]*2 else a[i]:=a[i]*3; end; writeln('Конечный массив: '); for i:=1 to n do write(' ',a[i]); end. б) const n=10; var a:array[1..n] of integer; i,k:integer; begin writeln('Исходный массив: '); for i:=1 to n do begin a[i]:=random(10); write(' ',a[i]); end; writeln; for i:=1 to n do begin if ((i mod 2) = 0) then a[i]:=a[i]-a[i]*2; end; writeln('Конечный массив: '); for i:=1 to n do write(' ',a[i]); end. 5 a) const n=10; var a:array[1..n] of integer; i,k:integer; begin k:=0; writeln('Исходный массив: '); for i:=1 to n do begin a[i]:=random(10); write(' ',a[i]); end; writeln; for i:=1 to n do begin if (i>2) and (a[i]>a[i-1]) then k:=k+1; end; writeln('Конечный массив: '); for i:=1 to n do write(' ',a[i]); writeln; write('Кол-во элементов больших соседа слева ',k); end. 5 б) const n=10; var a:array[1..n] of integer; z,i,k:integer; begin k:=0; z:=0; writeln('Исходный массив: '); for i:=1 to n do begin a[i]:=random(10); write(' ',a[i]); end; writeln; for i:=1 to n do begin if ((i mod 2) = 0) then k:=k+1; if k=2 then begin k:=0; z:=z+1; end; end; writeln('Конечный массив: '); for i:=1 to n do write(' ',a[i]); writeln; write('Кол-во четных пар: ',z); end. 6 а) const n=10; var a:array[1..n] of integer; s,k,i:integer; sr:real; begin s:=0; k:=0; writeln('Исходный массив: '); for i:=1 to n do begin a[i]:=random(10); write(' ',a[i]); end; writeln; for i:=1 to n do begin if ((a[i] mod 2) = 0) and ((i mod 2) <> 0) then begin s:=s+a[i]; k:=k+1; end; end; sr:=s/k; writeln('Конечный массив: '); for i:=1 to n do write(' ',a[i]); writeln; write('Среднее арифметическое четных элементов с нечетными индексами: ',sr); end.
4
Объяснение:
всего итераций цикла(повторений) 3,
с каждым шагом цикла мы вычитаем двойку из исходного числа=> 10-2=8
8-2=6
6-2=4