kirycha-2000719
?>

Pascal -напишите самую оптимальную программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером k и заканчивая элементом с номером m (включительно), вправо на r элементов.входные данные: первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 1 . в третьей строке через пробел записаны два числа – k ( 0 < k ≤ n ) и m ( k ≤ m ≤ n в четвертой строке записана величина сдвига r ( 0 ≤ r ≤ n ).выходные данные: программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.примеры: входные данные: 61 2 3 4 5 62 52выходные данные: 1 4 5 2 3 6

Информатика

Ответы

Panda062000

Program Exp_1;

Var

  a:array[1..5] of integer;

  i:integer;

Begin

    for i:=1 to 5 do

    Begin

     write('Vvedite ',i,'-yi element massiva ');

     Readln(a[i]);

    End;

Write('Ishodny massiv: ');

for i:=1 to 5 do

 write(a[i],' ');

writeln;

writeln('Poluchenny massiv: ');

for i:=1 to 5 do

 write(a[i]+5,' ');

 Readln;

End.

Program Exp_2;

Var

  a:array[1..10] of integer;

  i:integer;

Begin

    for i:=1 to 10 do

    Begin

     write('Vvedite ',i,'-yi element massiva ');

     Readln(a[i]);

    End;

Write('Ishodny massiv: ');

for i:=1 to 10 do

 write(a[i],' ');

writeln;

writeln('Poluchenny massiv: ');

for i:=1 to 5 do

 write(a[i]+5,' ');

for i:=6 to 10 do

 write(a[i]*5,' ');

 Readln;

End.

Program Exp_3;

Const

n=10;

Var

  a:array[1..n] of integer;

  i:integer;

Begin

    for i:=1 to n do

    begin

    a[i]:=5;

    write(a[i]:3);

    read;

    end;

End.

Ofelya1308

Требуется написать программу, вычисляющую значение какой-либо функции у = f(x). Допустим, такой:

у = x – 2, если x > 0,

y = 0, если x = 0,

y = |x|, если x < 0.

Решение

При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

В языке программирования Паскаль (да и в других тоже) желательно вложенные конструкции if - else помещать во внешнюю ветку else, а не if. Так проще не запутаться.

Таким образом, алгоритм вычисления значения функции может быть таким:

Если x > 0, то у = x - 2Иначе (ниже идет вложенная конструкция)Если x = 0, то y = 0Иначе y = |x|.

В последнем пункте можно опустить оператор if с проверкой, что x < 0, так как если ход выполнения программы дошел до этого пункта, то x уже другим быть и не может (варианты, когда он больше или равен нулю, уже были исключены).

Для определения модуля (абсолютного значения) переменной можно использовать встроенную функцию abs() языка Pascal. В данном случае можно обойтись и без нее: поскольку уже известно, что x отрицателен, то, чтобы получить положительное число (модуль), нужно его умножить на -1.

var x, y: integer;   begin write ('x = '); readln (x);   if x > 0 then y := x - 2 else if x = 0 then y := 0 else y := abs(x);   writeln ('y = ', y);   end.

Добавить комментарий

Комментарии

y=x^3

Гость (не проверено)09/01/2017

Запрограммируйте в языке паскаль вычисление куба числа x.

ответить

Решение вычисления куба

Гость (не проверено)16/01/2017

ответ на y=x^3 от Гость (не проверено)

var y, x : integer; begin write('введите x:'); read(x); y:=x*x*x; write (y); end.

ответить

сделал проще;)

mrX (не проверено)14/11/2020

ответ на Решение вычисления куба от Гость (не проверено)

program mrX;   var x,n:real; begin n:=3; write('введи число для куба = '); readln (x); writeln ('число равно = ',power (x,n)); end.

ответить

Вычислить чему равен y

Гость (не проверено)11/12/2015

Написать программу:

y=4x+10, если х>= 0;

y=8+х, если х<0.

ответить

Решение

Гость (не проверено)04/01/2016

ответ на Вычислить чему равен y от Гость (не проверено)

var x,y:integer; begin writeln('введите x = '); readln(x); if x>=0 then y:=4*x+10 else y:=8+x ; writeln(y) end.

ответить

Вычислить значение функции y = min + 2*min + b

Гость (не проверено)17/03/2015

Вычислить значение функции y = min + 2*min + b, определив и использовав функцию min, которая равна минимальному числу среди вводимых: a, b.

ответить

Решение

Гость (не проверено)05/07/2015

ответ на Вычислить значение функции y = min + 2*min + b от Гость (не проверено)

Program few2; Uses crt; Var a, b, y, min: integer; Begin ClrScr; Writeln('y:= min+ 2* min+ b'); Write('Значение a: '); Readln(a); Write('Значение b: '); Readln(b); If a>b then min:=a; If a<b then min:=b; y:= min+ 2* min+ b; Begin If a=b then Writeln('Невозможно найти значение...') else Begin Writeln('min= ', min); Writeln('y= ', min, '+ 2* ', min, '+ ', b); Writeln('Y= ', y); End; End; Readln; End.

ответить

Решение с определением функции

Гость (не проверено)03/09/2015

ответ на Вычислить значение функции y = min + 2*min + b от Гость (не проверено)

var a,b,y:integer; function K(var a1:integer;b1:integer):integer; var min:integer; begin min:=0; if(a1<b1) then min:=a1 else if (a1>b1) then min:=b1; writeln(min); K:=min; end; begin write('a,b='); read(a,b); K(a,b); y:=K(a,b)+2*K(a,b)+b; writeln('y=',y); end.

ответить

у = (х,если x<5)(2х, если x>=5)

Гость (не проверено)22/12/2014

Составьте программу для вычисления функции: у = (х,если x<5)(2х, если x>=5) - это система.

ответить

ответ

Гость (не проверено)13/09/2015

ответ на у = (х,если x<5)(2х, если x>=5) от Гость (не проверено)

Program p1; Var x,y:integer; Bgin ClrSxr; WriteLn("Введите Х"); ReadLn(x); If x<5 then WriteLn("Решения нет"); Else Begin y:=x*2; WriteLn(y); End; End.

ответить

Y=sqrt(sqrX + 5X + 3)

Гость (не проверено)01/12/2014

Необходимо составить таблицу значений функции Y=sqrt(sqrX + 5X + 3) на отрезке от 0 до 4 с шагом 0,25. Таблица должна выводится на экран в два столбца с заголовком "Х" и "f(X)".

ответить

Решение

Гость (не проверено)18/12/2014

ответ на Y=sqrt(sqrX + 5X +

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal -напишите самую оптимальную программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером k и заканчивая элементом с номером m (включительно), вправо на r элементов.входные данные: первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 1 . в третьей строке через пробел записаны два числа – k ( 0 < k ≤ n ) и m ( k ≤ m ≤ n в четвертой строке записана величина сдвига r ( 0 ≤ r ≤ n ).выходные данные: программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.примеры: входные данные: 61 2 3 4 5 62 52выходные данные: 1 4 5 2 3 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Бирюков Карпова1379
m-illarionov
Agadzhanyan-Ekaterina
Lidburg
margarita25061961
Yuliya_Viktoriya316
artemiusst
akarabut343
Pogosyan Nataliya
уровень 96 97 app balatech asia
ea9824165833886
krylova-natali
Михаил736
sakh2010kprf7
kryshtall2276
snopovajulia