MislitskiiSergei1403
?>

Напишите функцию search для поиска первого вхождения заданного значения в массиве целых чисел, которая как результат возвращает индекс найденного элемента.перегрузите эту функцию так, чтобы она могла работать с массивом вещественных чисел. в случае, если в массиве искомого элемента нет, функция должна вернуть значение -1.для двух массивов - целочисленного и вещественного - выведите индексы первого вхождения заданных элементов.формат входных данныхв первой строке вводится натуральное число n1 (n1 ≤ 1) - размер первого массива.в следующей строке вводятся n1 целых чисел, по модулю не превосходящих 109.далее вводится одно целое число, по модулю не превосходящее 109 - искомое значение.в следующей строке вводится натуральное число n2 (n2 ≤ 1) - размер второго массива.в следующей строке вводятся n2 вещественных чисел, заданных с точностью до 6 знаков после точки и по модулю не превосходящих 109.далее вводится одно вещественное число с точностью до 6 знаков после точки и по модулю не превосходящее 109 - искомое значение.формат выходных данныхв первой строке выведите результат поиска в первом массиве, а во второй -- во втором массивевходные данные568 52 14 61 9661630.89 58.12 3416 58.12 6.279 368.958.12выходные данные31​

Информатика

Ответы

msk27

Задание 2, 3 во вложении

Объяснение:

Задание 1.

Сначала вводятся переменные b и с через пробел.

Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.

затем идет условие.

Если с>b или b mod 2=0

Если 205>204 или

b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.

В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.

Первое и второе условие сработало, а значит выполняется следующее:

a:=b+2;

То есть в переменной а мы к b прибавляем 2. И у нас выходит:

a:=204+2=206

Условие иначе у нас не работает, поэтому выводим:

Writeln(a);

Программа выведет число а

206.


1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
MArat

Начнем сначала:

Определим объем одного символа.

256 символов соответстуют одному байту информации (или 8 битам). Количество бит можно посчитать по формуле log (256) по основанию 2. Он равен 8.

 

Значит один символ - это один байт. Теперь посмотрим какой объем информации содержит страница: 30*70 = 2100 байт.

Всего у нас есть 5 страниц текста:

2100 байт * 5 = 10500 байт информации.

 

По современной классификации это 10.5 килобайт информации.

По старой классификации (изучают в школах) это примерно 10.25 килобайт информации 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите функцию search для поиска первого вхождения заданного значения в массиве целых чисел, которая как результат возвращает индекс найденного элемента.перегрузите эту функцию так, чтобы она могла работать с массивом вещественных чисел. в случае, если в массиве искомого элемента нет, функция должна вернуть значение -1.для двух массивов - целочисленного и вещественного - выведите индексы первого вхождения заданных элементов.формат входных данныхв первой строке вводится натуральное число n1 (n1 ≤ 1) - размер первого массива.в следующей строке вводятся n1 целых чисел, по модулю не превосходящих 109.далее вводится одно целое число, по модулю не превосходящее 109 - искомое значение.в следующей строке вводится натуральное число n2 (n2 ≤ 1) - размер второго массива.в следующей строке вводятся n2 вещественных чисел, заданных с точностью до 6 знаков после точки и по модулю не превосходящих 109.далее вводится одно вещественное число с точностью до 6 знаков после точки и по модулю не превосходящее 109 - искомое значение.формат выходных данныхв первой строке выведите результат поиска в первом массиве, а во второй -- во втором массивевходные данные568 52 14 61 9661630.89 58.12 3416 58.12 6.279 368.958.12выходные данные31​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dannytr
elenalusia
info2
rinat
bestform
yurovolga
tatasi
kush-2640
Inforealto
pizniak
Bi-1704
Nikolaevich_Vladimirovich1509
maria
Vyacheslav_Nikolaevna
teashop
▲