Yuliya_Viktoriya316
?>

Составить программу, которая а) считает и возвращает количество букв, цифр, знаков б) любой гласный, подлежащий замене на букву «в» в), чтобы удалить часть предложения.паскаль

Информатика

Ответы

kurlasku

Считает  количество букв, цифр, знаков в строке

program test;

var a:string;

begin

read (a);

write(length(a));

end.

anovikovsr
ответ: да можно ,
Для каждого груза можешь привести 
Данный груз +   некая гиря     =  противовес 
1                     +     0                   = 1
2                     +     1                   = 3
3                     +     0                   = 3
4                     +     0                   = 3+1
5                     +     3+1               = 9
6                     +     3                   = 9
7                     +     3                   = 9+1
8                     +     1                   = 9 
9                     +     0                   = 9
10                   +     0                   = 9+1
11                   +     1                   = 9+3
12                   +     0                   = 9+3
13                   +     0                   = 9+3+1
julkamysh9
Все задачи однотипные, нужно знать понятия глубины цвета и как расчитывается объём для растрового изображения.
1.всего пикселей 128*128= 2^14(2 в 14-ой степени)
так как 32 цвет, то  один символ кодируется 5 битами (log2(32), если бы было 33 цвета то уже бы потребовалось 6 бит, так как 5 бы не хватило).
Нам нужно в килобайтах значит нужно разделить на 2^13 (т.к. в 1 кбайте 2^13 бит)

(2^14*5)/2^13=10 кбайт

2) (64*128*7)/2^13=(2^13*7)/2^13=7 кбайт
3)(64*256*8)/2^13= 2^17/2^13=2^4=16 кбайт
4)(32*1024*7)/2^13=(2^15*7)/2^13=4*7=28 кбайт
5)(1024*512*6)/2^13=(2^19*6)/2^13=64*6=384 кбайт
6)(512*256*5)/2^13=(2^17*5)/2^13=16*5=80 кбайт
7)(512*128*4)/2^13=2^18/2^13=2^5=32 кбайт
8)(256*128*3)/2^13=(2^15*3)/2^13=4*3=12 кбайт
9)(128*128*8)/2^13=2^17/2^13=2^4=16 кбайт
10)(24*2^13)/(128*256)=2^16*6/2^15=2*3=6 бит, значит 64 цвета
11)(10*2^13)/(128*128)=2^14*5/2^14=5 бит, значит 32 цвета
12)(7*2^13)/(64*128)=(7*2^13)/2^13=7 бит, значит 128 цветов
13)(16*2^13)/(64*256)=2^17/2^14=2^3=8 бит, значит 256 цветов
14)(28*2^13)/(32*1024)=7*2^15/2^15=7 бит, значит 128 цветов
15)(384*2^13)/(1024*512)=(3*2^20)/2^19=3*2=6 бит, значит 64 цвета
16)(80*2^13)/(512*256)=(5*2^17)/2^17=5 бит, значит 32 цвета
17)(32*2^13)/(512*128)=2^18/2^16=2^2=4 бита, значит 16 цветов
18)(12*2^13)/(256*128)=(3*2^15)/2^15=3 бита, значит 9 цветов
19)(16*2^13)/(128*128)=2^17/2^14=2^3=8 бит, значит 256 цветов (Каждый раз возводим в квадрат кол-во бит)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая а) считает и возвращает количество букв, цифр, знаков б) любой гласный, подлежащий замене на букву «в» в), чтобы удалить часть предложения.паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Arutyunovich
prostopo4ta29
bhg50
КалюкМарасанов1026
tatyanaryzhkova
osherbinin
Irina-Tunyan
hrviko
Кирилл_Гульницкий
Буду блогодарна уровень 6 класса
alex07071
Светлана-Тигран
mail5
Voronina747
Краева
vodexshop2
▲