sychevao19975
?>

Составьте программу (паскаль) для решения : в игре " лото" из мешка случайным образом выбираются бочонки , на каждом из которых написано число от 1 до 50. напишите программу, которая выводит наугад первые 3 выигрышных номера.​

Информатика

Ответы

Romanovna-yana

program Loto;

var

 L: array [1..50] of Integer;

 a: array [1..3] of Integer;

 i, j, n: Integer;

 b: Boolean;

begin

 for i := Low (L) to High (L) do

   L [i] := i;

 Randomize;

 for i := 1 to 3 do begin

   repeat

     n := Random (51) + 1;

   until L[n] <> 0;

   a [i] := L [n];

   L [n] := 0;

 end;

 for i := 1 to 3 do

   Write (a [i], ' ');

 ReadLn;

end

Объяснение:

сделана проверка чтобы 3 числа не совпадали друг с другом

fancy-decor67
Информатизация – это производное от слова информация. Информатизация – это процесс получения, использования, хранения, передачи информации.
На протяжении ХХ века сменялось множество обмена информацией. Если в XIX веке носителем информации была бумага, а средством передачи была почтовая служба, то в ХХ веке информация стала передаваться гораздо быстрее с телеграфа, в голосовой форме обмениваться информацией можно по телефону, радио и телевидение призваны только для получения человеком информации. В наши дни есть огромное количество передачи информации, причем в любой форме. Телефонные линии до сих пор остаются самым удобным средством передачи информации, но теперь ими обслуживаются не только телефоны, но и самое большое достижение процесса информатизации – Internet, содержащий большую часть информации со всей планеты.
Сейчас информатизация не мыслима без компьютера, так как он изначально создавался как средство обработки информации и только теперь он стал выполнять множество других функций: хранение, преобразование, создание и обмен информацией. Но прежде чем принять привычную сейчас форму компьютер претерпел три революции. Первая компьютерная революция свершилась в конце 50-х годов; ее суть можно описать двумя словами: компьютеры появились. Изобретены они были не менее чем за десять лет до этого, но именно в то время начали выпускаться серийные машины, эти машины перестали быть объектом исследований для ученых и диковинкой для всех остальных. Через полтора десятилетия после этого ни одна крупная организация не могла себе позволить обходиться без вычислительного центра. Если тогда заходила речь о компьютере, сразу же представлялись заполненные стойками машинные залы, в которых напряженно думают люди в белых халатах. И тут свершилась вторая революция. Практически одновременно несколько фирм обнаружили, что развитие техники достигло такого уровня, когда вокруг компьютера не обязательно воздвигать вычислительный центр, а сам он стал небольшим. Это были первые мини-ЭВМ. Но еще десять с небольшим лет, и наступила третья революция – в конце 70-х возникли персональные компьютеры. За короткое время, пройдя путь от настольного калькулятора до полноценной небольшой машины, ПК заняли свои места на рабочих столах индивидуальных пользователей.
Компьютер – это самое популярное средство для обработки, хранения и передачи информации и по сей день, но так как в наши дни информации становится все больше, то и компьютеры претерпевают значительные изменения. Для удобства пользователей стали выпускаться, переносные и карманные компьютеры, подключенные к глобальной информационной сети Internet, чтобы пользователь мог получить необходимую информацию в любом месте, в удобное для него время.
Но так как потоки информации только увеличиваются то для ее создания, обработки, хранения и передачи необходимо разрабатывать все новые и новые средства и при Существует множество компаний и корпораций, специализирующихся на разработках программного обеспечения, операционных систем, усовершенствовании и разработке новых более совершенных компьютеров, при для ввода и вывода информации, аксессуаров для удобства обращения с компьютером и ускорения обработки информации.
nekrasovaolga27
Был на свете человек он был обичный как все любил призидента и был нормальным но один раз когда он пошоо гулять с друзьями он упал в яму наткнувшись на блок он кго тронул и о него было видение потом его нашли копы работающие на призедента они розказали ему что Президент взорвет мир и только он мон мир с блока его хотели питать но пришел парень который его началась погоня и парень понял (его звали Дикарь) что человек (он де Эммет) не избранный продалдалась погоня и коп вистрельнул в Эммета пушкой (котороя не взривала а прилипила жучка)
Коп их стрелял но бэтмен их они полетели в Заоблачную даль
К другим крутим людям которие б им мир но из-за жучка прилетели копы и взорвали Заоблачную даль всех посадили в тюрмю но банда Эммета уцелела они пошли к Президенту гле их ожидали и словили все билы без но Эммет вибралса гле подертвовал собой для других и они закончили то что Эммет начал надавали люлей Президенту и копам и мир не взорвался а Эммет вижил!
Конец!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу (паскаль) для решения : в игре " лото" из мешка случайным образом выбираются бочонки , на каждом из которых написано число от 1 до 50. напишите программу, которая выводит наугад первые 3 выигрышных номера.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

diannaevaaa
nevasoundmsk36
Эрендженова
s45983765471717
teashop
delfa-r6289
symkifm
Dmitrievna Lvovich
Semenova1719
Диана820
Tamara
DmitrievnaVera
Мелконян1137
ktv665
vnolenev
▲