arnika-ooo1
?>

Три стороны одного треугольника и три другого. определить являются ли эти треугольники равновеликими т.е. имеют равные площади. составьте программу в системе basic

Информатика

Ответы

alenkadon6
Program factors;
var
num, sum : word;
st : string;
j : byte;

function fact(a : byte) : word;
var
res : word;
i : byte;
begin
res:=1;
for i:=1 to a do
res := res*i;

writeln(a, '!=', res);

fact := res;
end;

function vl(a : char) : byte;
var
res : byte;
begin
val(a, res);
vl := res;
end;

begin
write('Введите число: ');
readln (num);
str(num, st);
sum:=0;
for j:=1 to length(st) do
sum := sum + fact(vl(st[j]));
writeln('Сумма факториалов цифр числа равна: ', sum);
end.

Тестовый прогон программы:

Введите число: 125
1!=1
2!=2
5!=120
Сумма факториалов цифр числа равна: 123
nevori
1)
var a, b, c: integer; sr:real;
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
sr:=(a+b+c)/3;
writeln('Среднее арифметическое = ',sr);
end.

Пример:
a = 5
b = 2
c = 8
Среднее арифметическое = 5

2)
var a, b, c, s : integer; 
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
s:=0;
if a mod 2 = 0 then s:=s+a;
if b mod 2 = 0 then s:=s+b;
if c mod 2 = 0 then s:=s+c;
writeln('Сумма четных чисел = ',s);
end.

Пример:
a = 8
b = 5
c = 2
Сумма четных чисел = 10

3)
var a, b, c, max, min : integer; 
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
if a>b then max:=a else max:=b;
if c>max then max:=c;
if a<b then min:=a else min:=b;
if c<min then min:=c;
writeln('max = ',max,' min = ',min,'  Среднее = ',(max+min)/2);
end.

Пример:
a = 5
b = 2
c = 8
max = 8 min = 2  Среднее = 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Три стороны одного треугольника и три другого. определить являются ли эти треугольники равновеликими т.е. имеют равные площади. составьте программу в системе basic
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

glebovaludok
ambstroy
Бегун-Марина
Nekrasova
natanikulina1735
gk230650
maroseyka
sergey
Иван1764
LYuBOV
dokurova634
kulibabad566
oxy03214428
ЮлияНиколаевна1748
margusha1974
▲