xcho1020
?>

Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех заданных. после чего сообщает - является ли полученное произведение отрицательным или положительным

Информатика

Ответы

Yuliya mikhail

#include <iostream>

using namespace std;

int main()

{

 int a[4];

 int i, p;

 setlocale(LC_ALL, "russian");

 cout << "Введите четыре числа: ";

 for (i = 0; i < 4; i++) {

   cin >> a[i];

 }

 p = 1;

 for (i = 0; i < 4; i++) {

   p *= a[i];

 }

 if (p > 0)

   cout << "\nПроизведение положительно";

 else if (p < 0)

   cout << "\nПроизведение отрицательно";

 else

   cout << "\nПроизведение равно 0";

}

Nikolaevna382

Ваша программа:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

l = len(mas) # вычисляем длину списка (количество элементов)

for i in range( l ):

   if mas [i]==point:

       print("Содержит")

       break

   else:

       print ("Не содержит")

Можно ещё так записать:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

for i in mas: #смотрим каждый элемент в массиве

   if i == point:

       print("Содержит")

       break

   else:

       print ("Не содержит")

Можно написать так, что более понятно:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

if point in mas:

   print("Содержит")

else:

   print ("Не содержит")


Поиск заданного элемента в списке mas = [3,5,67,-65,34,21] # задаем списокprint(mas) ………………………………… [
tokarevmax

1.

а) Эргономика - это наука, изучающая взаимодействие между человеком и другими элементами системы для благополучия на рабочем месте.

b) Укажите угол наклона монитора: 15 градусов.

2.

1) человек лёг на стуле - его спина не ровная, плечи должны быть расслаблены и отпущены.

2) человек должен полостью прижать себя к стулу, чтобы ноги и спина были ровными, локти должны полностью лежать на столе.

3) его ноги находятся в прямом состоянии, а они должны быть под углом 90 градусов - ровно.

3. 1 поколение - ласковые машины

2 поколение - Полупроводниковые машины на транзисторах.

3 поколение - миникомпьютеры на интегральных схемах

4 поколение - По идее должно быть микропроцессоры, ну тогда Вычислительные системы на большой интегральной схеме

4. Не полная фотография, не видно вопрос

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех заданных. после чего сообщает - является ли полученное произведение отрицательным или положительным
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ruslan374
Валерьевна1601
servik78
Dmitrii sergei463
Станиславовна196
Полковников_Милана
Boykoyelena
Dmitrii_Shamilevich2019
Aleksandrovich-Yurevna1421
nyuraborova89
konstantinslivkov
Andreevna_Grebenshchikova155
stasyan
baumanec199613
MN-Natusik80