horina12
?>

Надо пара элементов в массиве называется симметричной , если эти элементы находятся на одинаковом расстоянии от концов массива. так в массиве размером n симметричными будут пары элементов с порядковыми номерами 1 и n , 2 и n - 1 и т.д. (при нумерации с единицы напишите программу, которая заполняет массив из n элементов случайными целыми числами в диапазоне [ a , b ] и определяет номера двух симметричных элементов этого массива, сумма которых чётная и максимальная среди всех пар симметричных элементов. если ни одной такой пары нет, нужно вывести два нуля. если есть несколько таких пар, нужно вывести номера элементов, составляющих пару, ближайшую к центру массива. входные данные входная строка содержит три числа: границы диапазона случайных чисел a и b , а также размер массива n . все числа разделены пробелами. гарантируется, что 0 < n ≤ 1 . выходные данные в первой строке программа должна вывести n элементов построенного массива, разделив их пробелами, а во второй строке – номера двух симметричных элементов массива, имеющих максимальную чётную сумму. если ни одной такой пары нет, нужно вывести два нуля. примеры входные данные 10 20 10 выходные данные 10 10 19 12 13 17 13 11 14 14 5 6 п.с. питон

Информатика

Ответы

АртакСергеевич1723
Информационным называют процесс, связанный с определёнными операциями (действиями) над информацией, в ходе которых может измениться содержание информации или её форма.
Виды информационных процессов
Среди всех информационных процессов можно выделить наиболее общие.

К ним относятся:

- получение,

- передача,

- хранение

- обработка информации.

Эти процессы являются базовыми.

Их выполнение порождает другие информационные процессы.

Так, например,

- получение информации может быть связано с её поиском, хранение — с накоплением;

- при передаче информации необходимо позаботиться о её защите от разрущающих воздействий.
Все процессы требуют той или иной формы представления информации, определяет которую процесс — кодирование. Он сопровождает все остальные процессы и является связующим звеном между ними.
Информационные процессы не изолированы, а протекают циклично в единстве и взаимосвязи друг с другом.
keldastrand
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Надо пара элементов в массиве называется симметричной , если эти элементы находятся на одинаковом расстоянии от концов массива. так в массиве размером n симметричными будут пары элементов с порядковыми номерами 1 и n , 2 и n - 1 и т.д. (при нумерации с единицы напишите программу, которая заполняет массив из n элементов случайными целыми числами в диапазоне [ a , b ] и определяет номера двух симметричных элементов этого массива, сумма которых чётная и максимальная среди всех пар симметричных элементов. если ни одной такой пары нет, нужно вывести два нуля. если есть несколько таких пар, нужно вывести номера элементов, составляющих пару, ближайшую к центру массива. входные данные входная строка содержит три числа: границы диапазона случайных чисел a и b , а также размер массива n . все числа разделены пробелами. гарантируется, что 0 < n ≤ 1 . выходные данные в первой строке программа должна вывести n элементов построенного массива, разделив их пробелами, а во второй строке – номера двух симметричных элементов массива, имеющих максимальную чётную сумму. если ни одной такой пары нет, нужно вывести два нуля. примеры входные данные 10 20 10 выходные данные 10 10 19 12 13 17 13 11 14 14 5 6 п.с. питон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kostmax1971
Сергеевич1386
Анатольевич-Лариса
Karmelita1978
varvara82193
extremhunter
Liliya-buc
Shcherbinin KOLIChEVA
antilopa001
osuvorova7979
NIKOLAI
sinicin80
tushina2020
Платон Демцун
КараханянКусков