navi35374
?>

Pascal.как-то раз мише понадобился треугольник, да не простой, а с заданной площадью s. для нахождения такого треугольника у миши есть листок тетради в клетку с нарисованным на нем квадратом размера 10 на 10 клеток. левый нижний угол этого квадрата имеет координаты (0, 0 вершины искомого треугольника он хочет поместить на пересечении вертикальных и горизонтальных линий листа в пределах этого квадрата. ему найти три такие точки, которые образуют треугольник заданной площади s и минимально возможным периметром. в качестве ответа миша ждет именно периметр такого треугольника с точностью до 3 знаков после десятичной точки. если же нет таких трех точек, которые образуют треугольник нужной площади, то вывести нужно -1.в первой строке входных данных дано натуральное число n, не превышающее 1 - количество моментов времени. во второй строке находятся n целых чисел, по модулю не превосходящие 1000 - описание перепадов напряжения в моменты времени. если число отрицательное, это значит, что в этот момент времени генератор не был активен и считать стабильность системы не нужно. если число положительное, это значит, что в данный момент времени генератор работает с перепадом напряжения в x единиц.формат результатавыведите одно число - ответ на .примерывходные данные53 -1 4 3 0результат работы2входные данные4-4 0 -2 -3результат работы0 .

Информатика

Ответы

ur101679

ответ: и это за 10 не глупи

объяснение:

emartynova25
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(7,1,99);
  var b:=ArrRandom(7,1,99);
  var c:=ArrRandom(7,1,2);
  var k:=0;
  var r,x:integer;
  for var i:=0 to 6 do begin
    Write(a[i]);
    if c[i]=1 then begin Write(' + '); r:=a[i]+b[i] end
    else begin Write(' - '); r:=a[i]-b[i] end;
    Write(b[i],' = '); Read(x);
    if x=r then k+=1
    end; // for
  Writeln('Верных ответов: ',k)
end.

Пример
77 - 21 = 56
53 - 97 = -44
91 + 51 = 142
42 - 65 = -23
70 + 78 = 148
91 - 5 = 86
45 + 41 = 86
Верных ответов: 7
NatalyaAlekseevich1644
Дано: 
Продолжительность фильма t=60 сек.,  разрешение монитора 800х600 пикселей, n - кол-во цветов 65536, s- частота 16 кадр/сек.
Найти V - Объем файла.

Решение: 
1. Определим глубину цвета i  по формуле: n=2^i = 65536 =2^i  i= 16 бит на пиксель
2. Размер одного кадра R = Разрешение монитора* i= 800*600*16 = 7680000 бит.
3. Тогда объем памяти одноминутного фильма равен V=R*s*t = 7680000*16*60=  7372800000 бит 
7372800000/8 = 921600000 байт
921600000/1024= 900000 Кбайт
900000/1024= 878,9 Мбайт

ответ: Объем памяти равен 878,9 МБ 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal.как-то раз мише понадобился треугольник, да не простой, а с заданной площадью s. для нахождения такого треугольника у миши есть листок тетради в клетку с нарисованным на нем квадратом размера 10 на 10 клеток. левый нижний угол этого квадрата имеет координаты (0, 0 вершины искомого треугольника он хочет поместить на пересечении вертикальных и горизонтальных линий листа в пределах этого квадрата. ему найти три такие точки, которые образуют треугольник заданной площади s и минимально возможным периметром. в качестве ответа миша ждет именно периметр такого треугольника с точностью до 3 знаков после десятичной точки. если же нет таких трех точек, которые образуют треугольник нужной площади, то вывести нужно -1.в первой строке входных данных дано натуральное число n, не превышающее 1 - количество моментов времени. во второй строке находятся n целых чисел, по модулю не превосходящие 1000 - описание перепадов напряжения в моменты времени. если число отрицательное, это значит, что в этот момент времени генератор не был активен и считать стабильность системы не нужно. если число положительное, это значит, что в данный момент времени генератор работает с перепадом напряжения в x единиц.формат результатавыведите одно число - ответ на .примерывходные данные53 -1 4 3 0результат работы2входные данные4-4 0 -2 -3результат работы0 .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vallod
alenih13
sv-rud
ghjcnjtyjn64
matoksana
turoverova5
Исаченко Тераски1181
yugraspets
horina12
alfastore4
jim2k
Stanislavovna1237
alexeytikhonov
Bella
yliana