Напишите программу: напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке [–5; 5] и находит сумму ненулевых элементов. на языке паскаля
// PascalABC.NET 3.0, сборка 1076 begin var n:=ReadInteger('Число элементов массива='); var a:=ArrRandom(n,-25,25); Write('Исходный массив: '); a.Println; var k:=a.Where(x->sqr(x)>sqr(a[0])).Count; if k>0 then Writeln ('Найдено ',k,' элементов, квадрат которых больше квадрата первого') else Writeln ('Нет ни одного элемента, квадрат которого больше квадрата первого') end.
Тестовое решение: Число элементов массива=15 Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16 Найдено 7 элементов, квадрат которых больше квадрата первого
superniki87
26.04.2020
1. Поменяны прописные и строчные буквы: закодированные слова начинаются со строчных букв, а остальные прописные, хотя в исходных словах все наоборот. 2. Длина слов сохранилась, как было три пятибуквенных имени и три шестибуквенных, так и осталось, следовательно одни символы были заменены на другие. 3. В имени Филипп две последние буквы совпадают и среди закодированных слов есть одно шестибуквенное тХКХОО, в котором совпадают две последние буквы. Также есть имя Максим, в котором первая и последняя буквы совпадают, а среди закодированных есть шестибуквенное лЮЙЯХЛ. На этом основании предполагаем, что произведена подмена одной буквы другой, причем подмена постоянная, т.е. конкретная буква всегда подменяется одной и той же. 4. Мы нашли два шестибуквенных имени, следовательно третье (Густав) закодировано как цСЯРЮБ. 5. Среди пятибуквенных имен два начинаются на одну и ту же букву (А), а среди закодированных имен есть два, начинающиеся на "ю", тогда оставшееся бЮДХЛ - это имя Вадим. 6. В слове юМРНМ совпадают вторая и последняя буквы. В имени Антон они также совпадают, следовательно оставшееся юПР╦Л - это Артём. Окончательно: юПР╦Л - Артём юМРНМ - Антон бЮДХЛ - Вадим лЮЙЯХЛ - Максим цСЯРЮБ - Густав тХКХОО - Филипп
begin
var n:=ReadInteger('Число элементов массива=');
var a:=ArrRandom(n,-25,25);
Write('Исходный массив: '); a.Println;
var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
if k>0 then Writeln
('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
else Writeln
('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.
Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого