Espivak
?>

Напишите программу в python (питоне), которая позволит проверять пароль на сложность. проверку пароля следует проводить по таким критериям: 1. длина: от 5 символов. 2. буквы латинского алфавита в верхнем и нижнем регистре: a, a, z, z. 3. цифры: от 0 до 9. 4. символы: @, #, %, & . рекомендации можете воспользоваться методом isnumeric() для проверки строки на наличие цифр. метод isupper() позволяет выполнить проверку букв в верхнем регистре, islower() следует использовать для проверки нижнего регистра. в свою очередь, isalpha() позволит определить символ в строке.

Информатика

Ответы

bristolhouse20151001
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
a60ikurgannikova
1) F=Av(¬A&B)
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB

2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B

3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B

4) F =(1v(AvB))v((AC)&1) 
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в python (питоне), которая позволит проверять пароль на сложность. проверку пароля следует проводить по таким критериям: 1. длина: от 5 символов. 2. буквы латинского алфавита в верхнем и нижнем регистре: a, a, z, z. 3. цифры: от 0 до 9. 4. символы: @, #, %, & . рекомендации можете воспользоваться методом isnumeric() для проверки строки на наличие цифр. метод isupper() позволяет выполнить проверку букв в верхнем регистре, islower() следует использовать для проверки нижнего регистра. в свою очередь, isalpha() позволит определить символ в строке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

efimov33
kryukovaem
svetavancevich
nikolai37
Mariya-Karaseva
Камочкин
laktionova-natal
fialkaflowers77
Olga1509
nat5555
Ананян Иван1281
tribunskavictory
Mikhailovna1444
Вайнер
catsk8