#include <iostream>
using namespace std;
int main()
{
int mas[20] = {};
int even = 0;
int odd = 0;
for (int i = 0; i < 20; i++)
{
cin >> mas[i];
}
for (int i = 0; i < 20; i++)
{
if (mas[i] % 2 == 0)
{
even++;
}
else
{
odd++;
}
}
if (even > odd)
{
cout << "Чётных больше.";
}
else if (odd > even)
{
cout << "Нечётных больше.";
}
else
{
cout << "Равное количество.";
}
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
using namespace std; // Пространство имён
int main()
{
int mas[20] = {}; // Создание целочисленного массива размерностью 20, заполненного нулями
int even = 0; // Создание целочисленной переменной, хранящей количество четных элементов
int odd = 0; // Создание целочисленной переменной, хранящей количество нечетных элементов
for (int i = 0; i < 20; i++) // Идём по массиву
{
cin >> mas[i]; // Вводим элементы массива с клавиатуры
}
for (int i = 0; i < 20; i++) // Идём по массиву
{
if (mas[i] % 2 == 0) // Если остаток от деления значения массива mas с индексом i на 2 = 0
{
even++; // +1 к четному
}
else // Иначе
{
odd++; // +1 к нечетному
}
}
if (even > odd) // Если значение переменной even > значения переменной odd
{
cout << "Чётных больше."; // Выводим ответ
}
else if (odd > even) // Если значение переменной odd > значения переменной even
{
cout << "Нечётных больше."; // Выводим ответ
}
else // Иначе
{
cout << "Равное количество."; // Выводим ответ
}
}
3)не (X и Y) или Z
Объяснение:
1) не (X и Y) и Z
Поскольку тут перед Z стоит операция И, то при Z = 0 всегда будет F = 0, поэтому такая функция исключается.
2) не (X или не Y) или Z
Поскольку тут перед Z стоит операция ИЛИ, то при Z = 1 будет F = 1. Проверим комбинации, где Z = 0.
Для X=0, Y=0 получаем
F = не (0 или не 0)
F = не (0 или 1)
F = не (1)
F = 0
Но в первой строке таблицы стоит 1, поэтому такая функция исключается.
3) не (X и Y) или Z
Здесь по Z рассуждения, как в 2).
Для X=0, Y=0 получаем
F = не (0 и 0)
F = не (0)
F = 1 - первая строка проверку.
Для X=0, Y=1 получаем
F = не (1 и 0)
F = не (0)
F = 1 - последняя строка проверку.
Функция подходит.
4) (X или Y) и Z
Рассуждения, как в случае 1), функция не подходит.
Поделитесь своими знаниями, ответьте на вопрос:
(написать программу на python) на большом поле находятся суслик и собака. собака хочет суслика съесть, а суслик хочет оказаться в безопасности, добежав до одной из норок, выкопанных в поле. ни собака, ни суслик в не сильны, но, с другой стороны, они и не беспросветно глупы. суслик выбирает определенную норку и бежит к ней по прямой с определенной скоростью. собака, которая хорошо понимает язык телодвижений, угадывает, к какой норке бежит суслик, и устремляется к ней со скорость вдвое большей скорости суслика. если собака добегает до норки первой (раньше суслика), то она съедает суслика; иначе суслик требуется написать программу, которая суслику выбрать норку, в которой он может если таковая существует. входные данные в первой строке записано два числа – координаты суслика. во второй строке записаны два числа – координаты собаки. в третьей строке записано число n – число норок на поле. в следующих n строках записаны координаты норок. все координаты являются целыми числами, по модулю не превышающими 1, и записываются через пробел. количество норок не превышает 1000. выходные данные нужно вывести число – номер норки, если у суслика есть возможность в ней если у суслика есть возможность спрятаться в нескольких норках, то выведите ту, которая первая шла во входных данных. если суслик не может то выведите «no» (без кавычек примеры: 10 10 20 20 1 15 15 no 20 20 10 10 2 15 15 25 25 2
ответ:
объяснение:
о