andrewa
?>

Составьте программу, которая делает «переключение» битов (toggle) во введенном пользователем числе m (тип unsigned char начальную позицию и количество переключаемых битов (идущих друг за другом) вводится пользователем с клавиатуры. выведите полученное число на экран. при вводе и выводе использовать представление в 16 системе счисления. пример: введеное число: 0xae (10101110) позиция 4 (индексы битов начинаются с 0) и количество - 3 результат: 0xde (1100) пользователь вводит с клавиатуры координаты трех точек: a (x1, y1), b (x2, y2), c (x3, y3). составьте программу, выводящую на экран координаты той точки, которая расположена ближе всех к центру координат (0, 0), и длину до него. переменные, хранящие координаты точек имеют тип double. (программа codeblocks)

Информатика

Ответы

savva-vika

#include<iostream>

using namespace std;

int main() {

   int down, upper, i, sum=0;

   cin>>down;

   cin>>upper;

   for(i=down; i<=upper; i++ )

       sum+=i;

   cout<<sum;

}

Объяснение:

Чтобы посчитать сумму чисел от какого-то (down) до какого-то (upper), нужно использовать цикл for.

Задаёшь эти самые границы (down и upper), цикл будет повторятся до тех пор, пока значение i не будет равно upper.

В теле цикла считаешь нужную сумму цифр. Как это работает? Очень просто! Когда программа доходит до этого цикла, она присваивает i значение down, затем прибавляет это значение i к sum. Потом программа возвращается к началу цикла, чтобы проверить значение i на соответствие верхней границе upper, если соответствует, то к значению i прибавляется 1 (так как в условии задано правило i++, то есть i=i+1 ) и снова срабатывает тело цикла, где к новой сумме прибавляется новое i (sum+=i – это sum=sum+i). Когда цикл заканчивается, срабатывает оператор вывода cout, который выводит новейшее значение sum.

Когда объявляешь переменные, не забудь оператору sum присвоить значение 0, так как сумма начинается с нуля

verynzik66525
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая делает «переключение» битов (toggle) во введенном пользователем числе m (тип unsigned char начальную позицию и количество переключаемых битов (идущих друг за другом) вводится пользователем с клавиатуры. выведите полученное число на экран. при вводе и выводе использовать представление в 16 системе счисления. пример: введеное число: 0xae (10101110) позиция 4 (индексы битов начинаются с 0) и количество - 3 результат: 0xde (1100) пользователь вводит с клавиатуры координаты трех точек: a (x1, y1), b (x2, y2), c (x3, y3). составьте программу, выводящую на экран координаты той точки, которая расположена ближе всех к центру координат (0, 0), и длину до него. переменные, хранящие координаты точек имеют тип double. (программа codeblocks)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

v79150101401
Iprokopova81
cometa94558
nat5555
larazaytseva
Pirogovskii695
А Дзукаев1562
leonid-adv70
I.B.Petrishchev
ВасилийМалюга152
siyaniemoskva
nord248
VSArsentev
АлександровнаВладимирович1424
bchukhraev79