alvs9
?>

Напишите программу в pascal выведите на экран все трехзначные числа, у которых последняя цифра четная

Информатика

Ответы

arbekova

var i: integer;

begin

for i:=100 to 999 do

if (i mod 10) mod 2=0

then write(i,' ');

end.

pelagia-kola2658

ответ:ОБЪЯВЛЕНИЕ МАССИВА

Массивы в Паскале используются двух типов: одномерные и двумерные.

Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.

Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:

Описание массива в Паскале

Объявление массива

var dlina: array [1..3] of integer;

begin

dlina[1]:=500;  

dlina[2]:=400;  

dlina[3]:=150;

...

dlina — идентификатор (имя) массива;

для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);

[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива

of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.

 

Объявить размер можно через константу:

размер массива через константу

ИНИЦИАЛИЗАЦИЯ МАССИВА

Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:

const a:array[1..4] of integer = (1, 3, 2, 5);

Заполнение последовательными числами:

заполнение массива

Результат:

A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1

Ввод с клавиатуры:

Пример: Рассмотрим, как происходит ввод массива в Паскале:

writeln ('введите кол-во элементов: ');

readln(n); {если кол-во заранее не известно, - запрашиваем его}

for i := 1 to n do begin

  write('a[', i, ']=');

  read(a[i]);

  ...

end;

...

Объяснение:

sirenashop25

Желі топологиясына жалпы анықтама • Желі топологиясының түрлері  Жұлдыз топологиясы • Сақина топологиясы • Шина топологиясы • Топологиялардың атқаратын қызметі • Артықшылықтары мен кемшіліктері • Желіні құру әдістері Желі топологиясы (ағылш. network topology) — есептеу желісіндегі машиналардың физикалық конфигурациясы, яғни қандай түйіндерЖелі топологиясы (ағылш. network topology) — есептеу желісіндегі машиналардың физикалық конфигурациясы, яғни қандай түйіндер жұбы өзара байланыса алатынын көрсететін физикалық жалғастыруды (немесе түйіндер арасындағы логикалық байланысты) бейнелеу; желілер жолдары мен тораптарын, олардың жол үзындығы, тораптар қуаты тәрізді сипаттамаларын ескермей, жалғастыру құрылымын зерттейтін қолданбалы ғылым. Желі топологиясының түрлері: • Жұлдызша • Сақина • Шина Желі топологиясының түрлері: • Жұлдызша • Сақина • Шина “Жұлдыз“Жұлдыз" тәрізді топология — барлық тораптары орталық бір тораппен жалғас- қан желі топологиясы. “Сақина “Сақина " тәрізді топология — әр торап басқа екі тораппен қосылған жәнбарлық тораптар бірге сақина құрайтын желі топологиясы. "Шина" тәрізді топология — барлық тораптары жалпы бір сызықтық ақпараттық арнаға қосылған компьютер желісінің архитектурасы. «Жұлдызды» түрінің топологиясына негізделген желіде әрбір жұмыс станциясы кабелі (бұралған жұп) хаб немесе«Жұлдызды» түрінің топологиясына негізделген желіде әрбір жұмыс станциясы кабелі (бұралған жұп) хаб немесе хабқа қосылады. Концентратор ДК-мен параллель қосылуды қамтамасыз етеді және осылайша желіге қосылған барлық компьютерлер бір-бірімен байланыса алады. Желі трансляция станциясының деректері барлық компьютерлерге барлық байланыс желілері бойынша хаб арқылы жіберіледі. Ақпарат барлық жұмыс станцияларына келіп түседі, бірақ ол тек қана жоспарланған станциялармен қабылданады. Физикалық жұлдыздың топологиясы бойынша сигнал беру эфирге беріледі, яғни ДК сигналдары бір мезгілде барлық бағыттарға таралады, сол кезде жергілікті желі логикалық топологиясы логикалық автобус болып табылады. Жұлдыздар топологиясының артықшылықтары: • жаңа компьютерді қосу оңай; • орталықтандырылған басқару мүмкіндігі бар; •Жұлдыздар топологиясының артықшылықтары: • жаңа компьютерді қосу оңай; • орталықтандырылған басқару мүмкіндігі бар; • Желі жеке компьютерлердің ақауларына және жеке компьютерлердің ажыратылуына төзімді. Жұлдызды топология желілерінің кемшіліктері: • Хабтың сәтсіздігі бүкіл желінің жұмысына әсер етеді; • Жоғары кабельді тұтыну.Сақиналы топологиясы бар желіде барлық түйіндер байланыс арналары арқылы деректердің тасымалданатын үзіліссіз сақинасына (міндеттіСақиналы топологиясы бар желіде барлық түйіндер байланыс арналары арқылы деректердің тасымалданатын үзіліссіз сақинасына (міндетті емес, шеңбер) қосылады. Бір компьютердің шығысы басқа компьютердің кірісіне қосылған. Қозғалысты бір нүктеден бастаған соң, деректер біртіндеп басталады. Рингтегі деректер әрқашан бір бағытта қозғалады. Алушы жұмыс станциясы тек оған жіберілген хабарламаны таниды және алады. Физикалық сақина түріндегі топологиясы бар желіде токенді қол жеткізу пайдаланылады, ол станцияны белгілі бір тәртіпте сақинаны пайдалану құқығын береді. Бұл желінің логикалық топологиясы логикалық сақина болып табылады. Сақина топологиясының желілерінің кемшіліктері: Бір жерде байланыс желісіне зақым келтіру немесе компьютердің жұмыс істемеуіСақина топологиясының желілерінің кемшіліктері: Бір жерде байланыс желісіне зақым келтіру немесе компьютердің жұмыс істемеуі бүкіл желінің жұмыс істемеуіне әкеледі. Бұл түрдегі топология барлық жұмыс станциялары қосылған жалпы кабель (шина немесе магистраль деп аталады).Бұл түрдегі топология барлық жұмыс станциялары қосылған жалпы кабель (шина немесе магистраль деп аталады). Кабельдің соңында сигналды көрсетуге кедергі келтіретін терминаторлар болады.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в pascal выведите на экран все трехзначные числа, у которых последняя цифра четная
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

laktionova-natal
ИП-Сысоев1628
expo3217
галина
ivanandrieiev1984268
kovalenko262
gre4ka2004
Nataliatkachenko1
deadnobody
MikhailSvetlana
Ruslan Zarekovkin
lider-mpl550
anchutk3016
Новицкий1107
lshimina65