Поделитесь своими знаниями, ответьте на вопрос:
Решить по c++ условие требуется вычислить разность двух чисел. формат входных данных на вход программе два целых числа a и b (∣∣a∣∣, ∣∣b∣∣≤109 формат выходных данных требуется вывести одно число: (a−b). входные данные выходные данные 5 3 выходные данные 2 условие ваша — посчитать квадрат, куб и пятую степень введенного числа формат входных данных с клавиатуры вводится число x (−50≤x≤50). формат выходных данных необходимо вывести на экран числа x2, x3 и x5. входные данные 2 выходные данные 4 8 32 условие с некоторого момента некоторое количество дней. сколько полных недель с этого же момента? формат входных данных вводится целое число x (0≤x≤231−1) — количество дней. формат выходных данных выведите целое число недель. входные данные выходные данные 10 15 выходные данные 1 2 условие напишите программу, которая считывает целое число и выводит сообщения о следующем и предыдущем перед ним. формат входных данных на вход программе дается одно целое число n (−200≤n≤200). формат выходных данных требуется вывести две строки, аналогичные в примере, подставив в них найденные числа. пробелы, знаки препинания, заглавные и строчные буквы важны! входные данные 179 выходные данные the next number for the number 179 is 180! the previous number for the number 179 is 178! условие требуется вычислить значение выражения (3x3+18x2)x+12x2−5. формат входных данных на вход подается одно целое число x (|x|≤150). формат выходных данных необходимо вывести одно число — значение выражения. входные данные 13 выходные данные 127252 условие дан порядковый номер дня года (отсчет идет с 1-го января). требуется вывести номер дня недели этого дня, если 1 января — понедельник. (запрещено использовать команду if) формат входных данных вводится номер дня года — целое число k (1≤k≤365). формат выходных данных выведите номер дня недели для данного дня года (понедельник — 1, вторник — 2, воскресенье — 7). входные данные 1 5 9 выходные данные 1 5 2 условие дан порядковый номер дня года k (отсчет с 1-го января). выведите номер дня недели этого дня, если 1 января — это заданный день недели под номером d. формат входных данных вводится номер дня года и номер дня недели 1 января — целые числа k (1≤k≤365) и d (1≤d≤7). формат выходных данных требуется вывести номер дня недели для данного дня года (понедельник — 1, вторник — 2, воскресенье — 7). входные данные 1 1 1 4 3 7 выходные данные 1 4 2
Задание 1
#include <iostream>
using namespace std;
int main() {
int a, b;
cin >> a >> b;
cout << a - b;
}
Задание 2
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int a;
cin >> a;
cout << pow(a, 2) << ' ' << pow(a, 3)<< ' ' << pow(a, 5);
}
Задание 3
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int a;
cin >> a;
cout << "The next number for the number " << a << " is " << a + 1 <<"!\n" <<"The previous number for the number "<< a << " is " << a - 1 <<"!";
}
Задание 4
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int a;
cin >> a;
cout << (3 * pow(a, 3) + 18 * pow(a, 2)) * a + 12 * pow(a, 2) - 5;
}
Задание 5
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int a, b, c;
cin >> a >> b >> c;
cout << a % 7 << "\n" << b % 7 << "\n" << c % 7;
}
Задание 6
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int a, b, c, a1, b1, c1;
cin >> a >> a1 >> b >> b1 >> c >> c1;
cout << a1 % (8 - a) << "\n" << b1 % (8 - b) << "\n" << c1 % (8 - c);
}