Петренко1852
?>

Составить программу для решения . даны 2 числа. если их разность неотрицательна, то каждое из чисел возвести в квадрат, и заверить числа их модулями в противном случае.​

Информатика

Ответы

Viktorovna1012

program Calc;

var

 a, b: Double;

begin

 Write ('Введите A и B: ');

 ReadLn (a, b);

 if a - b >= 0 then begin

   a := Sqr (a);

   b := Sqr (b);

 end else begin

   a := Abs (a);

   b := Abs (b);

 end;

 WriteLn ('A = ', a :10 :10, '  B = ', b :10 :10);

 ReadLn

end.

Galinova2911
А)uses crt;
const n=20;
var a:array[1..n] of integer;
i,s,k:integer;
begin
randomize;
s:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln(a[i]);
end;
writeln;
for i:=1 to n do
begin
if (a[i] mod 2=0) and (i mod 2 =0) and (a[i]<0)
then
begin
inc(k);
s:=s+a[i];
end;
end;
writeln(s);
writeln(k);
end.

б)uses crt;
const n=20;
var a:array[1..n] of integer;
i,s,k:integer;
begin
randomize;
s:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln(a[i]);
end;
writeln;
for i:=1 to n do
begin
if (a[i]mod 3=0) and (a[i] mod 5<>0) then
begin
s:=s+a[i];
inc(k);
end;
end;
writeln(s);
writeln(k);
end.

в)uses crt;
const n=20;
var a:array[1..n] of integer;
i,s,k:integer;
begin
randomize;
s:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln(a[i]);
end;
writeln;
for i:=1 to n do
begin
if (abs(a[i]))>(i-2)
then
begin
inc(k);
s:=s+a[i];
end;
end;
writeln(s);
writeln(k);
end.
Wlad967857
Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin      
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin  
If SunnyDay[i] = True
ThenBegin    
a := a + 2;    
If a > b Then    
a := b;  
End  
Else  
Begin   
a := a - 10;    
If a < 0 Then    
a := 0;  End;  
End; WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do
Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для решения . даны 2 числа. если их разность неотрицательна, то каждое из чисел возвести в квадрат, и заверить числа их модулями в противном случае.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sashulyah3183
Владимир-Денисович1080
vetrov1
Berezovskaya
dilshermatov5806
akudryashov
slazurnaya
Lenuschakova1982316
Вячеславовна_Сагитович
ziyaevak
atupicyn754
oksanamalakhova004610
vikgor45
Valentina
ajuli2