1
var
mas:array[1..100] of integer;
i,n:integer;
en,out:text;
res:real;
qw,qwe:string;
begin
n:=0;
i:=1;
write('Введите полный путь к импортируемому файлу: ');readln(qw);
write('Введите полный путь к экспортируемому файлу: ');readln(qwe);
assign(en,qw+'.txt'); assign(out,qwe+'.txt');
reset(en); rewrite(out);
while not Eof(en) do
begin
readln(en,mas[i]);
n:=n+mas[i];
inc(i);
end;
res:=(n/(i-1));
write(out,res);
close(out);
close(en);
end.
Там во вторую тупо добавляешь:
max:=-100001;
min:=100001;
if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];
if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];
if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')
else
begin
writeln(out,min);
writeln(out,max);
Тоже такие же задачи решал)) лол). Ты не из 604??)))
Поделитесь своими знаниями, ответьте на вопрос:
Дано два натуральных числа а и в. напишите программу, которая находит цифру, на которую заканчивается число а в степени b (ab
#include <cmath>
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL,"RUS");
unsigned long a,b;
cout<<"Введите число а"<<endl;
cin>>a;
cout<<"Введите число b"<<endl;
cin>>b;
cout<<((unsigned long)pow(a,b))%10;
system("pause");
return 0;
}
C#using System;
class Power {
static int Main() {
ulong a, b;
Console.WriteLine("Введите число а");
a=Convert.ToUInt64(Console.ReadLine());
Console.WriteLine("Введите число b");
b=Convert.ToUInt64(Console.ReadLine());
Console.WriteLine(Math.Pow(a,b)%10);
Console.ReadKey();
return 0;
}
}
Pascalprogram Power;
uses crt;
var
a,b,c:Int64;
i:byte;
begin
writeln ('Введите число a');
readln(a);
writeln ('Введите число b');
readln(b);
c:=1;
for i:=1 to b do
c:=c*a;
writeln (c mod 10);
end.