vasearu
?>

Нужно, буду . отсортировать массив по не убыванию методом распределения по массиву ключей, по не возрастанию. язык pascal. ​

Информатика

Ответы

borisova-Sergeevna
Для примера со сложением чисел 25 учениками попробуйте проанализировать следующие ситуации: в классе всего 1 кусок мела; в классе 5 кусков мела; в классе 25 кусков мела. оцените, как от этого зависит время решения (учтите ещё ширину доски и время перемещения учеников по классу) попробуйте построить модель такого процесса. переведите эту ситуацию на язык компьютерной терминологии для многопроцессорных систем. 2) попробуйте примеры алгоритмов поиска информации в массиве и сортировки массива, которые допускают распараллеливание операций. опишите процедуру распараллеливания. сколько процессоров необходимо для эффективного распараллеливания в вами примере?
Джамалутдинова Докучаев

Пример на продукте - бананы

program v1;

var m,n,sum,t:integer;

st1:string[10];

 begin

   sum:=0; t:=0;

   writeln('Здравствуйте');

   writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');

   writeln('Сколько купите бананов '); readln(n);

  writeln('Введите цвет бананов '); readln(st1);

   if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;

   if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей')  then sum:=2500*n;

   if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный')  then sum:=3700*n;

   writeln('Сумма покупки ', sum);

   writeln('Введите сумму'); readln(m);

   t:=m-sum;

   writeln('Возьмите сдачу ',t);

   writeln('Всего доброго, приходите еще');

 end.


Дорогие программисты по информатике! Напишите программу по этим алгоритмам умоляю

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно, буду . отсортировать массив по не убыванию методом распределения по массиву ключей, по не возрастанию. язык pascal. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ganzashop
Sergei1805
Bogataya Vladimir318
ekasatkina
Chuhnin195107364
Сергеевич1386
sn009
puchkovajulia
lider-mpl550
teya07
yurievaalxndra55
kisuhakisa
vallzh8328
Жуков219
shilinmikhaillg