igorSvetlana547
?>

Известно количество осадков выпавших за первые 7 дней октября в течении 2х лет. написать программу определяющую верно ли что кол-во осадков за первый год превысило соответствующее колличество 2-го года? паскаль

Информатика

Ответы

konstantin0112

program test;

var a,b:integer;

begin

writeln('Какое количество осадков в сумме выпало за первые 7 дней октября в первый год?');

readln (a);

writeln('Какое количество осадков в сумме выпало за первые 7 дней октября во второй год?');

readln (b);

if a>b then write ('Верно');

if a<b then write ('Неверно') else

write ('Осадки за первый год равны осадкам за второй год');

end.

Борисовна_Кашутина
200₁₀ → x₂

Делим число в десятичной системе на основание числа, которое мы хотим получить, то есть на 2:

200 / 2 = 100 (0), где 0 - это остаток. Действительно, 2 · 100 + 0 = 200

100 / 2 = 50 (0)

50 / 2 = 25 (0)

25 / 2 = 12 (1), 2 · 12 + 1 = 24 + 1 = 25. Это можно представить так: у Вас есть 25 яблок и 2 друга, между которыми нужно поровну разделить все яблоки. Вы можете обоим дать только по 12 яблок, а останется 1. Это и будет остаток.

12 / 2 = 6 (0)

6 / 2 = 3 (0)

3 / 2 = 1 (1)

1 / 2 = 1 (1), применим на том же примере с яблоками: у нас есть одно яблоко и 2 друга, а нужно разделить количество яблок поровну, не деля яблоко пополам. У Вас сделать это не получится, поэтому у Вас остаётся 1 яблоко, то есть остаток.

Теперь "собираем" остатки снизу вверх:

11001000₂ - это и будет наш двоичный код.

ответ

11001000

Avdeeva Inga1505
1)Потому что информацию мы в скором времени забудем. А оперативная память-временная. Примеры:кол-во денег которое мне надо взять с собой что бы доехать завтра до вокзала; номера упражнений по геометрии которые надо сделать дома до завтра.
2)Достоинства оперативной памяти: не занимает место в долговременной, через некоторое время удалится(если речь про компьютер); позволяет возвращать несколько действий назад(например в ворде)
Недостатки: загружает компьютер; малое кол-во памяти
Достоинства долговременной памяти: почти не затормаживает компьютер; большое кол-во памяти
Недостатки: Поиск файлов может занять некоторое время; не вся информация может туда загрузится

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известно количество осадков выпавших за первые 7 дней октября в течении 2х лет. написать программу определяющую верно ли что кол-во осадков за первый год превысило соответствующее колличество 2-го года? паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zoyalexa495
TrubnikovKlimenok926
priexali
dashanna04225
tigran87-87
Александровна
tarigor
Александра_Наталья1417
borodin
Viktorovich395
platan3698952
drozd228758
Strelkov-Roman1263
Нескажу25
daverkieva568
▲