Ямпольский
?>

C# написать программу, демонстрирующую все разработанные элементы класса. 1. создать класс point, разработав следующие элементы класса: о поля: ■ int х, у; о конструкторы, позволяющие создать экземпляр класса: ■ с нулевыми координатами; ■ с заданными координатами. о методы, позволяющие: ■ вывести координаты точки на экран; ■ рассчитать расстояние от начала координат до точки; ■ переместить точку на плоскости на вектор (а, ь о свойства: ■ получить-установить координаты точки (доступное для чтений и записи); ■ позволяющие умножить координаты точки на скаляр (доступное только для записи).

Информатика

Ответы

sbelova

ответ:

напишите нормально а то так непонятно

tanu0618

Ақпараттық технологиялар саласы негізінен екі тәуелсіз циклде дамиды: өнімділік және қаржылық. Жақында біз қаржылық циклде екендігіміз туралы көптеген даулар болды; қаржылық нарықтарға көп көңіл бөлінеді, олар кейде өзін болжай алмайтындай ұстайды және қатты өзгеріп отырады. Екінші жағынан, өнімнің циклдеріне онша назар аударылмайды, дегенмен олар ақпараттық технологияны алға жетелейді. Бірақ өткен тәжірибені талдай отырып, сіз қазіргі өнім циклын түсінуге және технологиялардың болашақ дамуын болжауға тырыса аласыз. Жоғары технологиялар саласындағы өнім циклдарының дамуы платформалар мен қосымшалардың өзара әрекеттесуі арқылы жүреді: жаңа платформалар жаңа қосымшаларды құруға мүмкіндік береді, бұл өз кезегінде осы платформалардың құнын арттырады, осылайша оң кері байланыс циклін жабады. Шағын өнім циклдары үнемі қайталанып отырады, бірақ тарихи түрде 10-15 жылда бір рет тағы бір үлкен цикл басталатындай дамыды - бұл АТ-ны толық өзгертетін дәуір.

Объяснение:

krisrespect
Дорога, соединяющая города i и j, даст единицу в две позиции - (i, j) и (j, i). Тогда общее количество единиц в матрице равно удвоенному числу дорог. Отсюда и простое решение - считать N^2 чисел, подсчитать количество единиц и поделить его на 2. Можно считать и сумму - от этого ничего не изменится.

   #include <iostream> 
   int main() {
       int n = 0, sum = 0, temp = 0;
       std :: cin >> n;
       for (int i = 0; i < n * n; i++) {
           std :: cin >> temp;
           sum += temp;
       }
       std :: cout << sum / 2;
       return 0;
   }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C# написать программу, демонстрирующую все разработанные элементы класса. 1. создать класс point, разработав следующие элементы класса: о поля: ■ int х, у; о конструкторы, позволяющие создать экземпляр класса: ■ с нулевыми координатами; ■ с заданными координатами. о методы, позволяющие: ■ вывести координаты точки на экран; ■ рассчитать расстояние от начала координат до точки; ■ переместить точку на плоскости на вектор (а, ь о свойства: ■ получить-установить координаты точки (доступное для чтений и записи); ■ позволяющие умножить координаты точки на скаляр (доступное только для записи).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kashtanov Anna
mmihail146
koochma
milanmilan8672
opal19575
ivanpetrovichru1801
dannytr
juliaWinter
prianik6
Anna-Miron
Aleksandrivanovna
raa-0485428
Yelizaveta1848
andyrvo
Yevsyukov1697