Veronika343
?>

Дано натуральное число в котором все цифры различны, определить разряд в котором находится максимальная цифра, надо написать программу на с#

Информатика

Ответы

gbfedak220

using System;

using System.Linq;

using static System.Console;

class Program

{

static void Main()

{

int x=int.Parse(ReadLine());

var t=x.ToString().Select(n=>(int)n).Reverse().ToList();

WriteLine((t.FindIndex(n=>n==t.Max())+1).ToString());

}

}

gumirovane2294

Данное выражение истинно тогда и только тогда, когда истинно хотя бы одно из следующих выражений: xy+A10 или (x (*); Важно понимать, что последнее выражение невозможно сделать истинным при любых переменных. Действительно, всегда можно выбрать y=A; Поскольку y\geq 0, то можно выбрать y=0 и гарантированно обеспечить ложность последнего выражения. Тогда x\times0+A10 \Leftrightarrow A10; Значит A хотя бы 11, все меньшие значения опровергаются значением y=0; Докажем, что A=11 подходит: в силу xy\geq 0 имеем xy+A\geq 1110 - это выражение верно, а, значит, верно и все выражение (при любых переменных), благодаря (*).

fixer2006

int main() {

string sistema;

cin >> sistema;

if (sistema == "пятибалльная") {

int ocenka;

cin >> ocenka;

switch (ocenka) {

case 2 : cout << "Неудовлетворительно";

case 3 : cout << "Удовлетворительно";

case 4 : cout << "Хорошо";

case 5 : cout << "Отлично"

}

}

if (sistema == "двенадцатибалльная") {

int ocenka;

cin >> ocenka;

switch(ocenka) {

case 2 : cout << "два";

case 3: cout << "три";

case 4 : cout << "4";

case 5 : cout << "5";

case 6: cout << "6";

case 7 : cout << "7";

case 8: cout << "8";

case 9: cout << "9";

case 10 : cout << "10";

case 11 : cout << "11";

case 12 : cout << "12";

}

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число в котором все цифры различны, определить разряд в котором находится максимальная цифра, надо написать программу на с#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

allaraygor
elozinskaya
narkimry134
Vladimir
Кирилл-Анна1023
moonligh3560
Borg Fedak1162
parolmm
gbelihina
gladkihvv
novdodCT
Баринова
mir5552
annasv8
garikman-flesh486
▲