михаил
?>

Вигре лото из мешка случайным образом выбираются бочонки, на каждом из которых написано число от 1 до 90.напишите программу, которая выводит наугад первые 5 выигрышных номеров. доработайте программу так, чтобы все 5 значений были гарантированно разными выполнять в паскале a b c !

Информатика

Ответы

vovkiv7864

const

 n = 5;

var

 i, j, k: integer;

 a: array[1..n] of integer;

 p: boolean;

begin

 randomize;

 for i := 1 to n do

   repeat

     k := random(90) + 1;

     j := 1;

     p := True;

     while p and (j < i) do

       if a[j] = k then

         p := False

       else

         j := j + 1;

     if p then    

       a[i] := k;

   until p = True;  

 for i := 1 to n do

   write(a[i], ' ');

end.

snabdonm501

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Объяснение:

Roman913

Принтер (ағылш. printer) — мәтін мен кескіндерді қағазға немесе басқа да басып шығарылатын арқауларға шығаруға арналған құрылғы, ЭЕМ-ның ақпарат басып шығаруға арналған перифериялық құрылғыларының бір түрі. Баспа таңбаларын басу әдістеріне қарай Принтерлер матрицалық, сия құюшы ағыстық, (струйный), лазерлік, жарықаласыдиодтық, жылулық, сублимац., т.б. болып бөлінеді. Принтердің негізгі техникалық сипаттамаларына оның айыру қабілеті, басу жылдамдығы, материалдардың шығындылығы, фото басу мүмкіндігі, т.б. жатады.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вигре лото из мешка случайным образом выбираются бочонки, на каждом из которых написано число от 1 до 90.напишите программу, которая выводит наугад первые 5 выигрышных номеров. доработайте программу так, чтобы все 5 значений были гарантированно разными выполнять в паскале a b c !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osipov1984osipov
severbykova
russstep
Avetisyan575
raa-0485428
Donleksa2016
andre6807
stertumasova29
st-op767840
nekrasovaolga27
osandulyak
snk7777202
Бондарен1076
Puschdom
Yevgenevich
▲