evageniy79
?>

Си ++, , , нужно написать программу с оператором while, которая будет включать пользовательскую функцию для вычисления значения z

Информатика

Ответы

vadimnechaev23150

Исходник ниже.

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   //"\t" - табуляция

   //fixed - для вывода фиксированного количества знаков после запятой у вещественного числа

   cout << "x\t\ty\t\ta\t\tb\t\tz" << endl;

   double x = 0.5;

   while(x <= 1.9){

       double y = 0.1;

       while(y <= 0.2){

           double a = cos(x*x*x - sqrt(y));

           double b = pow(x * y * y, 1.0 / 3);

           double z;

           if (a > b){

               z = a;

           }

           else{

               z = b;

           }

           cout << fixed << x << "\t" << y << "\t" << a << "\t" << b << "\t" << z << endl;

           y += 0.05;

       }

       x += 1.1;

   }

   return 0;

}

pastore
Домик⇒северная стена⇒окно.                                                                               Домик⇒южная стена⇒окно.                                                                                     Домик⇒восточная стена⇒дверь правая⇒ручка                                                                                              ⇒дверь левая⇒ручка                                                                                                                      ⇒нижний замок                                                                                                        ⇒верхний замок                                         Домик⇒западная стена⇒окно                                                                                 Домик⇒крыша
Anastasiya81
Домик⇒северная стена⇒окно.                                                                               Домик⇒южная стена⇒окно.                                                                                     Домик⇒восточная стена⇒дверь правая⇒ручка                                                                                              ⇒дверь левая⇒ручка                                                                                                                      ⇒нижний замок                                                                                                        ⇒верхний замок                                         Домик⇒западная стена⇒окно                                                                                 Домик⇒крыша

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Си ++, , , нужно написать программу с оператором while, которая будет включать пользовательскую функцию для вычисления значения z
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

федороа
antrotip
Vladimirovna1370
agaloan8
Татьяна1856
ИП-Сысоев1628
cheshirsky-kot
Pilotmi247074
Ионов202
sveta740450
rusplatok
vladburakoff5
predatorfishing608
ovdei71
ПодлеснаяМакарова1883