составить блок схему и написать программу на языке с# по : дан массив, содержащий 14 элементов.все отрицательные элементы заменить на 3.вывести исходный и полученный массив.
Начнем с того, что мах десятичное 4-хзначное число это 9999. мах сумма будет 9*4=36 мах произ-ие 9*9*9*9=6561 невозрастание это убывание или равенство
Число 63 разделим его на 2 числа, т.к. вычисляются 2 числа. Получаем 6 и 3. 6 и 3 - убывание 1) Предположим, что 6-произведение, а 3-сумма, тогда 6=2*3*1*1 (4 числа, т.к. по условию у нас 4-хзначное число), но тогда 3=2+3+1+1. Значит неправильное предположение. 2) 3-произведение, а 6-сумма, тогда 3=3*1*1*1, а 6=3+1+1+1. Все сходится. Вывод: число 63 нам подходит.
Число 89. числа 8 и 9. возрастание. Вывод: не подходит
Число 98 9 и 8. убывание 1) Начнем с того, что 9-произведение, а 8- сумма 9=3*3*1*1, 8=3+3+1+1 Вывод: подходит
Число 200. 20 и 0. И никак иначе. Т.к. чисел 2 и 00 быть не может. убывание 1) 0-логично, что это пр-ие, т.к. суммой быть не может, значит 20-сумма 20=9+9+2+0 Вывод: подходит
Число 291. числа 29 и 1, т.к. только так у нас будет убывание. 1) 1 суммой быть не может. 29-сумма, однако если 1-пр-ие, то только 1=1*1*1*1, но 29≠1+1+1+1 Вывод: не подходит
Число 1311 только 13 и 11 ни 13 ни 11 не могут быть пр-ием, т.к. умножаться и складываться могут только числа от 0 до 9 Вывод: не подходит
Число 656136. Видно, что мы можем поделить его на 6561 и 36. убывание. Оба числа-максимумы, значит Вывод: подходят
Число 756423. Одно из чисел не может быть больше 36, а также порядок невозрастания должен соблюдаться. Значит 7564 и 23. Одно из чисел все равно не входит в мах, значит Вывод: не подходит
ответ:4
P.S. Фух, это было трудно, но надеюсь, что
murin
11.03.2022
Type ta=array[1..10] of integer;
var f:text; s:string; i,k:integer; ar:ta;
procedure change(var ar:ta; i:integer; var k:integer); begin; if (ar[i]>5) and (ar[i]<10) then begin; ar[i]:=100; inc(k); end; end;
begin; randomize; k:=0; writeln('First array:'); for i:=1 to 10 do begin; ar[i]:=random(30); write(ar[i]:4); change(ar,i,k); end; assign(f,'text.txt'); rewrite(f); writeln(f,'Final array:'); for i:=1 to 10 do write(f,ar[i]:4); writeln(f,' '); writeln(f,'Changes:',k); close(f); end.
#include <iostream>
using namespace std;
int main()
{
int a[14];
for (int i = 0; i < 14; i++)
{
a[i] = rand() % 20 - 10;
cout << a[i] << " ";
}
for (int i = 0; i < 14; i++)
{
if (a[i] < 0)
{
a[i] = 3;
}
}
cout << endl<<endl;
for (int i = 0; i < 14; i++)
{
cout << a[i] << " ";
}
}
Объяснение: