catsk8
?>

Даны действительное число х не равное нулю и число n целое. составить программу и вычислить сумму ряда s​

Информатика

Ответы

lion13

var

 i, n: integer;

 x, s, a, xn: real;

 

begin

 read(n, x);

 a := 1;

 s := 1;

 xn := 1;

 for i := 1 to n do

 begin

   a := a * (2 * i - 1) / sqr (2 * i);

   xn := xn * x;

   s := s - a * xn;

 end;

 write(s * Pi / 2);

end.

sarycheva659
Интернет – одно из самых удивительных изобретений 20-го века. Он дает безграничные возможности в отношении различных коммуникаций, получения и хранения нужной информации, направлении мультимедиа. Отношение к нему различных слоев населения неоднозначно, содержит даже диаметрально противоположные позиции, но огромное значение его в жизни современного человека не будет оспариваться никем.

Эта слайдовая презентация является результатом ученического исследования на тему влияния интернета на жизнь человека и на все общество в целом. На ее слайдах рассматриваются вопросы:

- Что же такое интернет,

- Использование интернета в жизни людей,

- Как интернет влияет на людей,

- Интернет для ребенка,

- Можем ли мы прожить без интернета,

- Интернет в отдельном школьном классе,

- Личное отношение автора к интернету.
Геннадьевна_Петр
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
function
Transpose(a: array[,] of integer): array[,] of integer;
//Поворот на 90гр по часовой стрелке
begin
  var m := Length(a, 0);
  var n := Length(a, 1);
  Result := new integer[n, m];
  for var i := 0 to n-1 do begin
    for var j := 0 to m-1 do
      Result[i, j] := a[m-1-j, i];
  end;
end;

begin
  var n := ReadInteger('Введите n:');
//Заполнение матрицы NxN сл. числами и вывод на экран
  var a :=MatrixRandom(n, n);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(a[i,j]);
    println;
    end;
     println;

  Println('поворот влево на 90 гр');
  var b := Transpose(a);
  b:=Transpose(b);
  b:=Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
  println;

  Println('поворот вправо на 90гр');
  b := Transpose(a);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
 println;

 Println('поворот на 180 гр');
  b := Transpose(a);
  b := Transpose(b);
  for  var i:=0 to n-1 do begin
    for var j:=0 to n-1 do
      Print(b[i,j]);
    println;
    end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны действительное число х не равное нулю и число n целое. составить программу и вычислить сумму ряда s​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alisa
cholga69
Sharap
Баринова
Vyacheslavovich-Gubanov
Васильев1028
m-illarionov
ajuli2
denbelousov963
aleksey7800
Nv-444
yamalsva45
Алёна Геннадьевна98
adman7
Vera-zero281