lor005148
?>

Pascal. составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области​

Информатика

Ответы

Ubuleeva826

Вы извините, что здесь пишу, в графе для ответов. Хочу Вам просто и код, и скриншот прикрепить. Попробуйте этот код (комментарии условны, только для понимания). Три числа введите через пробел, в соответствии с логикой конечно же (смотрите комментарии для лучшего понимания):

# k - максимальное количество котлет на сковороде

# m - прожарка котлеты с одной стороны

# n - входное количество котлет

k,m,n = map(int, input().split())

time_am = 0

if (n <= k):

   time_am += 2*m

elif (n > k):

   while (n > k):

       time_am += 2*m

       n -= k

       if (n <= k):

           time_am += 2*m

           break

print(time_am)


Пайтон Я хотел выполнить задание на курсерах Тренировочное задание по программированию: Котлеты*
АнтонАртем

#include <iostream>

#include <vector>

using namespace std;

void group_multiply(vector<int> &a, int l, int r, int x){

   for(int i = l; i <= r; i++)

       a[i] *= x;

}

signed main(){

   const int n = 10;

   vector<int> a(n);

   int num = 0, max_elem = -INT_MAX;

   for(int i = 0; i < n; i++){

       cin >> a[i];

       if(a[i] > max_elem){

           max_elem = a[i];

           num = i+1;

       }

   }

   group_multiply(a,n-5,n-1,num);

   for(auto &i:a)

       cout << i << " ";

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal. составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dshi67orbru
Кононова-БЕСКРОВНАЯ
elenaperemena8
Dragun1684
smint056950
виталийВячеславович
zhandarmova
алексеевич810
strelnikov-aa
stalker2201
Городничий_Коновалова384
artem-dom
muravlev2702
maestro6838
korolev-comitet8825