Коновалова
?>

Написать программу которая рассчитывает 10! использовать цикл с параметром ( счётчиком) и цикл с предусловием. большое

Информатика

Ответы

elenachuxina804

Program fact10;

var

i:byte;

fact:longint;

begin

writeln('Цикл с параметром');

fact:=1;

for i:=2 to 10 do

fact:=fact*i;

writeln('10! = ',fact);

writeln('Цикл с предусловием');

fact:=1;

while (i<>1) do

begin

fact:=fact*i;

i:=i-1;

end;

writeln('10! = ',fact);

end.

Абдулганиева Сергей
1) Фраза "Лень делает всякое дело трудным" содержит 31 символ; объем высказывания = 31*8 = 248 бит
2) Строка "И трижды тот вооружен, кто прав!" содержит 32 символа; объем строки = 32*16 бит = 32*16 / 8 байт = 64 байта
3) 0,5 Кбайт = 0,5*1024 байт = 0,5*1024*8 бит
Количество символов в сообщении = 0,5*1024*8 / 8 = 512
4) Объем текста = 60*25*5*8 бит = 60*25*5*8 / 8 байт = 7500 байт
5) Объем рассказа = 4*48*64*8 бит = 4*48*64*8 / (8*1024) Кбайт = 12 Кбайт
6) Объем статьи = 12*64*64*16 бит = 12*64*64*16 / (8*1024) Кбайт = 96 Кбайт
7) Объем сообщения = 30*1 байт = 30*8 бит = 240 бит
8) Объем реферата = (12*48*64 + 12*24*32)*2 байт = (12*48*64 + 12*24*32)*2 / 1024 Кбайт = 90 Кбайт
9) 24 Кбайт = 24*1024*8 бит. Для кодирования каждого символа используется 24*1024*8 / (8*40*64) = 9,6 ≈ 9 бит (а может быть и 8 бит).
10) 30 Кбайт = 30*1024*8 бит. Количество страниц = 30*1024*8 / (20*48*16) = 16
Vikkitrip
1. Назовите первое вычислительное устройство.
1) Абак

2. Какую идею выдвинул в середине 19 века английский математик Чарльз Бэббидж?
1) Идею создания программно управляемой счетной машины, имеющей арифметическое устройство, устройство управления, а также устройство ввода и печати

3. Назовите первого программиста вычислительных машин.
1) Ада Лавлейс

4. В каком году и где была создана первая ЭВМ на основе электронных ламп?
1) 1945 год, США

5. На какой базе были созданы ЭВМ третьего поколения?
1) Интегральные схемы

6. Как назывался первый персональный компьютер?
1) Apple I

1. Назовите центральное устройство компьютера.
1) Процессор

2. Как записывается и передается физическая информации в ЭВМ?
3) представляется в форме электрических сигналов.

3. Процессор обрабатывает информацию представленную:
4) На машинном языке (в двоичном коде)

4. Для ввода числовой и текстовой информации используется
1) Клавиатура

5. Важнейшей характеристикой координатных устройств ввода является разрешающая которая обычно составляет 500 dpi (dot per inch – точек на дюйм (1 дюйм = 2,54 см)), что означает…
1) При перемещении мыши на один дюйм указатель мыши перемещается на 500 точек

6. Сканер используется для…
1) Для ввода в компьютер изображений и текстовых документов

1. Какой тип принтера целесообразно использовать для печати финансовых документов?
1) Матричный принтер

2. Какой тип принтера целесообразно использовать для печати рефератов?
3) Лазерный принтер

1. Какой тип принтера целесообразно использовать для печати фотографий?
2) Струйный принтер

2. При несоблюдении санитарно – гигиенических требований компьютера вредное влияние на здоровье человека может оказать…
1) Монитор на электронно – лучевой трубке

3. Устройство, которое обеспечивает запись и считывание информации называется…
1) Дисководом или накопителем

4. При выключении компьютера вся информация стирается из…
4) Оперативной памяти

13. В каком устройстве компьютера осуществляется хранение информации?
1) Внешняя память;

2. Оптические дорожки имеют меньшую толщину и размещены более плотно на …
1) Цифровом видеодиске (DVD – диске)

3. На каком диске информация хранится на концентрических дорожках, на которых чередуются намагниченные и ненамагниченные участки
1) На дискете

4. В устройства ввода входят…
1) Клавиатура, мышь, джойстик, световое перо, сканер, цифровая камера, микрофон

5. В устройства вывода входят…
2) Звуковые колонки, монитор, принтер, наушник

6. Программой называется…
1) Последовательность команд, которую выполняет компьютер в процессе обработки данных

7. Компьютерная программа может управлять работой компьютера, если она находится…
1) В оперативной памяти

8. Данные – это…
2) Информация, представленная в цифровой форме и обрабатываемая на компьютере

9. Файл – это…
3) Программа или данные, имеющие имя и хранящиеся в долговременной памяти

10. При быстром форматировании гибкого диска …
1) Производится очистка каталога диска

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая рассчитывает 10! использовать цикл с параметром ( счётчиком) и цикл с предусловием. большое
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

avdushinalizza1
semenovakotya577
yelena
sorokinae
westgti77105
muziumednogorsk
tvtanya80
terehin863
Probitbiz6
gordeevadesign2986
Диана820
bikemaster
muzeynizhn
orion-inginiring7807
sredova71121