aivanova
?>

Составить программу на паскале. в двумерном массиве хранится информация о количестве учеников в каждом классе каждой параллели школы с первой по одиннадцатую (в первой строке — информация о классах первой параллели, во второй — второй параллели и т. в каждой параллели школы имеются четы-ре класса. определить общее число учеников в параллели 5-х и 10-х классов. используйте процедуру.

Информатика

Ответы

rusmoney92

#include <iostream>

#include <ctime>

#include <Windows.h>

using namespace std;

int main()

{

   SetConsoleCP(65001);

   SetConsoleOutputCP(65001);

   string word;

   int g;

   long int t1 = time(NULL);

   string n = "0123456789ABCDEFG";

   string f = "ty"; // Зачем это нужно, если оно нигде не использовано?

   int k = 0;

   for (auto a : n)

       for (auto a1 : n)

           for (auto a2 : n)

               for (auto a3 : n)

                   for (auto a4 : n)

                   {

                       word.push_back(a);

                       word.push_back(a1);

                       word.push_back(a2);

                       word.push_back(a3);

                       word.push_back(a4);

                       cout << word << endl;

                       g = word.length(); // тоже что-то мутное зачем длинна слова? она всегда равна 4

                       word.clear();

                       // не понял прикола if g == g, это всегда истина. поэтому убрал его

                       k++;

                   }

   long int t2 = time(NULL);

   cout << "Время выполнения (сек): " << t2 - t1 << endl; // с выводом слова на экран у меня работает 341 сек ~ 5,5 минут. без - 0 сек

   cout << "Всего вариантов в " << g << " степени " << k << endl;

   // a = input(":") // Это что вообще? =_= // если хотел чтобы оно не закрывало окно - используй system("pause");

   int a;

   cout << ":";

   cin >> a;

   

   return 0;

}


(Python 3.8) import timecur_time = time.time()n = 0123456789k = 0for a in n: for a2 in n: for a3 i
Lukina

class Program

 {

   static void Main(string[] args)

   {

     string src = " Qwy. ... Asdf.. Lkjdfs A.";

     //string dest = ReplaceDots(src, '.', '…', 3);

     string dest = ReplaceDots(src, '.', "...", 3);

 

     Console.WriteLine("src:\t" + src);

     Console.WriteLine("dest:\t" + dest);

 

     Console.WriteLine();

     Console.Write("Press any key for exit ...");

     Console.ReadKey(true);

   }

 

   //private static string ReplaceDots(string src, char dotCh, char dots, int minDotsCount)

   private static string ReplaceDots(string src, char dotCh, string dots, int minDotsCount)

   {

     StringBuilder dest = new StringBuilder();

 

     int i = 0;

     while (i < src.Length)

     {

       int dotsCount = 0;

       while (i < src.Length && src[i] == dotCh)

       {

         dotsCount++;

         i++;

       }

 

       if (dotsCount >= minDotsCount)

         dest.Append(dots);

       else if (dotsCount == 0)

         dest.Append(src[i++]);

       else

         while (dotsCount-- > 0)

           dest.Append(dotCh);

     }

 

     return dest.ToString(); ;

   }

 }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на паскале. в двумерном массиве хранится информация о количестве учеников в каждом классе каждой параллели школы с первой по одиннадцатую (в первой строке — информация о классах первой параллели, во второй — второй параллели и т. в каждой параллели школы имеются четы-ре класса. определить общее число учеников в параллели 5-х и 10-х классов. используйте процедуру.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aidapiltoyan43
murin
AndreevManaeva
Li-111
Серопян
Вячеслав
Alyona
infosmolenskay
sleek73
KseniGum9
dksvetlydir
ale99791308
Budanov317
remontsalarievo2
Вершинина1161